Reducing DOSX Conventional Memory

  Andy 999 12:26 10 Oct 2008

Hi, is everyone ok?

Ill keep it short and sweet.

Basically, i over look the operation of a business network at a company. The software they use to manage their finances and transactions is a DOS Program, run in XP. However, they have had a new machine installed, and they can not use the software correctly. During use, the software comes up with an error notifying the user that there is insufficient conventional memory to run the program properly.

Ive run 'mem /c' on the computer that works and on one that does.

On the working PC, Conventional Memory for 'DOSX' is 0k, with an upper memory usage of 34K for DOSX.

On the machine that doesnt work, DOSX's conventional memory is 33.9K, and its Upper memory set at 0.1K.

I have tried fiddling with config.nt and autoexec.nt, but to no avail. I have spoken to the softwares technical department and they guided me in the direction that drivers could be interfering, taking up valuable memory, which, in dos, is limited to a conventional memory of 640K.

Ive disabled legacy USB drivers and onboard audio etc but to no avail. Any ideas??????

Any suggestions are greatly appreciated as this has been doing my nut in for the past 3 days.


  DieSse 12:32 10 Oct 2008

Have you simply tried running it in compatibility mode?

  Andy 999 13:00 10 Oct 2008

Yes, ive tried that but it didnt work. Ive just been doing more research, a possible solution is that if the network redirector loads before dosx, then that can affect where the dosx is loaded.Ive tried this on one machine and it seems to have worked maybe, however on another it hasnt. I also read that drivers loaded in BIOS stage could affect this, anyone heard anything about that??

click here

That is a similar thread however as it is 4 years old it can only be used as reference material..

Cheers, andy

  PO79 13:51 10 Oct 2008

Have you considered DOSBox click here I've yet to encounter a DOS programme it can't run.

  PO79 14:03 10 Oct 2008

I have checked my autoexec.nt file, copied below

@echo off

REM AUTOEXEC.BAT is not used to initialize the MS-DOS environment.
REM AUTOEXEC.NT is used to initialize the MS-DOS environment unless a
REM different startup file is specified in an application's PIF.

REM Install CD ROM extensions
lh %SystemRoot%\system32\mscdexnt.exe

REM Install network redirector (load before dosx.exe)
lh %SystemRoot%\system32\redir

REM Install DPMI support
lh %SystemRoot%\system32\dosx

REM The following line enables Sound Blaster 2.0 support on NTVDM.
REM The command for setting the BLASTER environment is as follows:
REM where:
REM A specifies the sound blaster's base I/O port
REM I specifies the interrupt request line
REM D specifies the 8-bit DMA channel
REM P specifies the MPU-401 base I/O port
REM T specifies the type of sound blaster card
REM 1 - Sound Blaster 1.5
REM 2 - Sound Blaster Pro I
REM 3 - Sound Blaster 2.0
REM 4 - Sound Blaster Pro II
REM 6 - SOund Blaster 16/AWE 32/32/64
REM The default value is A220 I5 D1 T3 and P330. If any of the switches is
REM left unspecified, the default value will be used. (NOTE, since all the
REM ports are virtualized, the information provided here does not have to
REM match the real hardware setting.) NTVDM supports Sound Blaster 2.0 only.
REM The T switch must be set to 3, if specified.
SET BLASTER=A220 I5 D1 P330 T3

REM To disable the sound blaster 2.0 support on NTVDM, specify an invalid
REM SB base I/O port address. For example:

Does yours have the LH switches in the three lines like mine, that loads into the high memory area.

  Andy 999 14:46 10 Oct 2008

@ pO79, yea my autoexec.nt is like yours. I switched the 'redir' line with the dosx line, and it worked on one machine, but not on others.. I have DOSBox, however im unsure as to whether it will work with their software. I'm at the office at the moment, so i cant really remote in and have a fiddle whilst they are working. Will i have to change any settings with the software or will it work 'as is'? Ive never used DOSBox or the software they use....

Cheers, Andy

  PO79 15:09 10 Oct 2008

You shouldn't have to change any settings for the programme to run in DOSBox. Just a thought, as the problem seems to relate to accessing the High Memory area, have you tried removing the LH switches, and allowing them to load "Low", then maybe the programme concerned will have enough "High Memeory" to work.

  Andy 999 16:36 10 Oct 2008

Ive tried that, it frees up conventional memory, however DOSX doesnt seem to have loaded at all as it is not mentioned in mem /c or mem /d. Is it possible it could be the BIOS loading a driver before windows starts, hence the upper memory is already used prior to windows booting?!?!

  Andy 999 18:12 11 Oct 2008


  PO79 13:46 12 Oct 2008

In the config.nt file (see mine below) try changing the second line to

dos=high, umb

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?