RealVNC & Dyamic IP Address

  kentylad 21:18 23 Nov 2004

I am trying to access my PC remotely, and having come to the conclusion that I do in fact have a static IP (i.e. it changes every time I connect to the internet), I decided to download 'No-IP Dynamic Update Client'. Thus, I now have a domain name in the form of '' (or similar) which registers my curreny IP address (in the form 82.8.x.x) with this domain.

I then decided to download 'RealVNC Enterprise Edition' which is a remote access server. However, this only seems to pick up my Network IP (in the form 192.168.x.x), not my ISP IP (in the form 82.8.x.x).

Is there a way I can change RealVNC to use my No-IP domain?

Kind regards


  kentylad 09:08 24 Nov 2004

No router. We have two switches; One connected to the cable modem and 2 pc's downstairs, as well as a link to another switch upstairs to which I am connected. Can I forward my TCP settings here?

  nyleridedog 12:01 24 Nov 2004

what isp yer on?

if you have a 192ip, ergo he is using a router and naturally VNC is picking up your lan ip.
you need to set up port forwarding on the router to map the VNC ports to the lan ip address and then just type your address in broswer and bobs your uncle.

  kentylad 13:36 24 Nov 2004

Ok. I have a Belkin F5D5230-4 router, and I am on NTL.

Now I have found this link click here on forwarding for this router, however it hasn't worked as of yet...

So, just a reminder of my situation - VNC is using 192.1.168.*.* (Internal) on port 5901 where as 'No-IP' is using 82.8.*.* (External)

Any ideas for setup? Thanks

  kentylad 14:13 24 Nov 2004


  kentylad 14:32 24 Nov 2004

I have set the 'Virtual Server' settings as follows (from the link I Posted earlier):

1. Private IP: 192.168.*.* (Replacesd *'s)

Private Port: 80 (not sure on this? Set it default HTTP hence 80)


Public Port 5900

I have also done exactly the same but with Public Port as 5800 as well

  nyleridedog 15:04 24 Nov 2004

what are you using to login?

browser or vnc?

  nyleridedog 15:16 24 Nov 2004

Ok, here's an example of how its done, change the relevant details for your own lan

Router -- ip = 82.x.x.x
PC -- ip = 192.168.1.x
Use TightVNC as opposed to real VNC, slightly better compression and encoding options.
On the router's config you should allocate port forwarding on port 80 to port 5800 and point all forwarded traffic to the LAN ip (192.168.1.x) This covers the VNC webserver. Any requests that hit the router on port 80 should go straight to the LAN ip above and connect into port 5800 (default vnc web server port).
Do another port forward setup for the VNC viewer. Personally I forward port 443 (SSL (hhtps)) through to the default port (as above on same LAN ip) 5900.
This means than when you enter the address in a web browser it will open the session on port 80 through the router straigh to you pc for remote access. If you work in an proxied environment using port443 assists in bypassing the proxy (especially if using a citrix session) and also makes the session secure.
Obviously when using the VNC viewer, just enter the address foloowed by the relevant number. ie

Thats how I set mine up. I have complete access from even the most restrictive environemnts.



Back to you Nyleridedog.......

  kentylad 20:06 24 Nov 2004

Ok, i have uploaded a picture of the forwarding settings for my here

Should this work on a remote computer? Can i test the settings from another computer connected to the same router?


  kentylad 22:57 24 Nov 2004

have changed to TightVNC - Still no connection as of yet

  nyleridedog 12:34 25 Nov 2004

Sorry about the delay, Nyleridedog said you'd posted some info.
Havinf difficulty viewing your pwp. If you want some more direct tech support mail me at [email protected] and I'll help you get it online.



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)