Reading old HD in caddy

  UncleP 21:55 02 Jun 2006

I've taken an IDE HD from my now-defunct old Windows ME computer, placed it in an appropriate caddy and connected it to my newish WinXP machine. The intention was to wipe it and use it as an image and data file back-up. At this point it occurred to me that it would be sensible to look at its contents just in case there was anything left on it worth keeping.

However, I'm not sure how to do this, or even if it's possible at this stage. It is recognised in the Disk Management window as Disk03 (but no drive letter), with the right capacity and manufacturer's details, but is marked as not initialized and unallocated. Right-clicking brings up a sub-menu with an 'initialize' option, but I thought this was equivalent to re-formatting it so I'm reluctant to try it.

It's not vital, as all the important stuff was backed up and transferred to the new computer. But any comments or advice would, as always, be gratefully received.

  kjrider 22:28 02 Jun 2006

Have you changed the jumper on the HD from Master to Slave?

Also your ME HD may be FAT32 instead of NTFS. Don't know if this might make it unrecognised.

  UncleP 10:22 03 Jun 2006

I should have said that the caddy is a standard USB2 model; I had read somewhere that the HD jumper should be left in the Master position with these - but as I've said elsewhere my memory is less than perfect these days. I'll give it a try.

The file format is certainly FAT32, but I think WinXP will recognise this ok. When wiping it for further use, I was going to change to NTFS.

Thanks for the suggestions!

  Fruit Bat /\0/\ 10:29 03 Jun 2006

Yes jumper must be at master in a caddy
XP will read Fat32.

If its showing up in Disk manager then connections ok

If you don't want contents the right click select initialise and then format.

  Ikelos 10:31 03 Jun 2006

as much as i tried i could not get mine to read the contents, i think you will find it needs the rest of the PC to link to. so in the end i reformatted it and now we have a 60gb storage unit.

  gudgulf 11:20 03 Jun 2006

You might be better opening the computers case and connecting the old drive to one of the IDE channels as a slave.

That should enable you to read the contents and retrieve any usefull files.

Then put it back in the caddy and initialise/format it for use as an external backup drive.

  UncleP 22:02 03 Jun 2006

Thanks for the comments - sorry about the delay in replying, I've been enjoying the sunshine (and a couple of beers) down at my sports club.

As I haven't much to lose, I tried a few options:-

(a) looked up 'initialise' in the Help and Support index: basically detects the disk and assigns status and type to it. No mention of formatting, so clicked on this in the LHS sub-menu for Disk 3 on the Disk Management window. After a delay, obtained 'Basic' and 'Online' for this disk - a step forward, I hoped.

(b) right-clicking on the RHS of the disk 3 entry brought up another sub-menu, which enabled the disk to be made active and to assign it a drive letter (K:)

(c) when I tried to look at the drive content, it came up with 'drive not formatted'. In the properties display, the file system was given as RAW, with zero used space and zero free space. So it hasn't recognised the FAT32 format.

(d) when I started to format the disk, it warned that all data would be lost if I continued - so I didn't. But this is probably issued automatically, and doesn't mean that it knows that there is data actually present.

And there I'm stuck for the present. I'd prefer not to mount the disk as a slave in the new computer if I can avoid it. So if any of you guys can make some sense of the above, change your login to 'Gungha Din'!

  woodchip 22:18 03 Jun 2006

The drive jumper will only run as a Master for a USB caddy. it will not work if it's set to Slave

  UncleP 21:47 05 Jun 2006

Having run out of practical tests to run on the computer, I've spent the afternoon Googling around trying to find explanations of the results above, especially in (c). Initially found nothing, which made me suspect it's not a general problem but specific to my system.

Then found that the report of the RAW file format and the 'drive not formatted' message often indicated corruption of either the boot sector or the FAT. So I ran a demo version of a disk recovery program I had downloaded, which not only correctly identified the FAT32 file system but - rather slowly - found the rest of the 60,000-odd files and estimated that they were nearly 100% recoverable. As they did indeed include a few that I had forgotten about and might be worth rescueing, I now have to decide if they are worth paying the fee ($80) to up-grade to the full version of the program.

Also, as I don't know how the disk was corrupted, it means that if I use it for back-up and storage I will need to run the WD Smart utility to measure and monitor its performance.

Anyhow, thanks to all who responded for their comments and interest - I hope I haven't wasted your time. I'll tick the thread as resolved tomorrow if there are no more suggestions or questions by then.

  woodchip 22:04 05 Jun 2006

You could use Acronis Disc Director 10 to recover the Partition click here

click here

I use both the above 12:09 06 Jun 2006

Excellent post UncleP.

Good of you to report your findings.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review: Hands-on

How to add texture to hand-drawn artworks

Best free iPad apps 2018

Comment créer un compte PayPal pour payer en ligne ?