"We can't create a recovery drive on this pc" error with Windows 8.1

  Jwbjnwolf 01:07 27 Oct 2013

Hi, does anybody know how to sort out this problem with Windows 8.1 create a recovery drive tool... "We can't create a recovery drive on this PC. Some required files are missing. To troubleshoot problems when your PC can't start, use your Windows installation disc or media"?

After I upgraded Windows 8 to 8.1 on my mac in Bootcamp and on my laptop, I decided to use Winclone 3.7 to transfer Windows from Bootcamp onto my external HDD, but (I think this is Parallels to blame), I cannot boot because prl_pv32. sys is corrupted (which is a parallels file).

Any way, I downloaded the 8.1 ISO from Microsoft (using the close win 8 setup at 1% and opening 8.1 setup method - worked no prob to get the ISO), and I managed to get through the refresh process, only to find that it was Bootcamp it refreshed, not the clone, so I've backed up the few app installs that I don't want to lose (such as GTA etc with all it's mods so I can copy the folders back over after all this), and deleted Bootcamp, and I tried again, but the clone can't even boot the repair options where you select refresh, troubleshooting etc, so I put a usb stick in my laptop to do the create a recovery drive, and it came out saying my usb stick was too small (was fine for windows 8, but 8.1 requires 500mb), so I created a partition on my external HDD, to try with that only to realise it replaced the clone of windows, so cloned it back over, and I searched for my 1gb memory stick, but now the create a recovery drive tool says it can't find the required files.

I backed up (created DMG with disk utility) the recovery drive partition on my external HDD before I copied windows back over, and I've tried restoring that to my usb stick, but disk utility says "cannot repartition target device" (such a great utility disk utility is, but then it loves moaning when restoring DMGs etc). So i am not sure what to do now.

Booting into the install usb I created of windows 8.1 I downloaded, that only allows you to completely install, it doesn't give you the options to refresh so I need the create a recovery drive to work so I can get into the refresh options. Anyone know?

Just do annoying,anything and everything just decides to not work when you need it to lol.

I decided to move windows to my external HDD because then it won't interfere when I try booting anything linux. (I will eventually get a enclosure for the HDD in my dell and put windows on that so I can use this HDD for simply just Backups again.

Thanks for any help


  Jwbjnwolf 01:13 27 Oct 2013

Sorry about the length of the post btw, I wrote about 3x the length and then looked at it and thought "hang on a sec, I'm gonna scare help off by writing an essay", and that's as far as I managed to cut it down to so sorry it still a bit long lol.

  Jwbjnwolf 15:44 28 Oct 2013

Well I've come across now that the Windows Store is saying it's broken due to some missing files.

So annoying this is

  Jwbjnwolf 14:44 24 Nov 2013

Well I am starting to get somewhere now...

I tried to refresh my laptop because Skydrive is now all messed up completely and it is saying every file on my laptop (from Skydrive) is missing etc, so I can't use it for college until that's sorted so I tried refreshing, it said that it cannot refresh because it can't find any recovery media... annoying.

Then I played around for hours with parallels, to try and install windows 8.1 with a generic key from the esd usb I created. I eventually worked out that I needed to "click new, then when it asks for install media, I click continue without media, then I choose windows 8 as the type, i check the box to say it is 64bit, then I start the VM and then in the toolbar click "devices" then "usb" then choose my usb stick. Then I stop the VM, open the settings , click hardware, then boot order, then I check use EFI boot.

Next thing I know is that the usb boots up. Finally!!!! now I will be able to create a recovery usb to get to the refresh options, so I can then chose to refresh from the 8.1 usb installer.

First I will refresh Windows on my Mac, then I will do it on my laptop. Talk about long, but at least I am getting somewhere now after lots of frustration with my USB sticks, and frustration with mouse too haha as it's dead low on battery so it's keep shutting off all the time (don't ask why I haven't changed the batteries yet lol.

Parallels is a big time savor

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?