Hot Topics

"System Restore" doesn't restore system!

  KeithMH 12:20 31 Jan 2013

I'm busy reinstalling Vista (Home Basic) and was happily installing updates when Windows Update suggested them. I appear to have installed SP1 (it shows 4 times in "update history") but "Windows Update" continues to offer SP1 for download. Also, if I try to install SP2, I get a message telling me that I need to install SP1 first. I've tried "System Restore" repeatedly using all available restore points, but I keep getting a message that an "Unspecified error occurred during System Restore".

Can anyone help?

Many thanks.

  Ventad 13:16 31 Jan 2013

I had this happen with system restore, I found the only way around it was to use it in "safe mode". (Start the computer and keep tapping F8)

  northumbria61 15:35 31 Jan 2013

I would turn off "Automatic Updates" and then go to Control Panel - Programs and Features - Windows Updates - and remove ALL 4 updates that show SP1 and start again.

  KeithMH 19:02 31 Jan 2013

Many thanks for your replies.

When I tried to uninstall the four instances of SP1, they didn't appear in the list.

Then I used F8 and went for the Repair option. So far so good, but, of course, it's back to the long slog of downloading and installing. Fingers crossed.

  KeithMH 09:37 01 Feb 2013

Well, I'm back in the same position again.

Update History shows SP1 as successfully installed, but it doesn't show under "Uninstall an update". Also, Windows Update is asking me to install it again. It doesn't come up when I use "winver".

Windows Update won't even open under Safe Mode.

  northumbria61 12:07 01 Feb 2013

Take a look at some suggestions here enter link description here

  KeithMH 10:40 02 Feb 2013

Thanks for that. I'll put it behind my ear for next time.

I've actually solved my problems via

Many thanks for your help, northumbria61 and Ventad.

  KeithMH 10:44 02 Feb 2013

That link hasn't come out right. I'll have another go.

  KeithMH 10:50 02 Feb 2013

Ther are underscores between windows & vista and between windows & update, which keep disappearing when I press "Post".

This thread is now locked and can not be replied to.

1x1 pixel
Elsewhere on IDG sites

For Microsoft, 2020 is a year of profound change

Inspiring Creative Projects in response to Pandemic & Protest

First glimpse of iPhone 12 packaging

Coronavirus : quel type de masque acheter et où le trouver en ligne ?