Question mark in device manager

  martin p 17:35 11 Sep 2007

Trying to load an external USB hard drive ( no Drivers needed) on to my PC It reconises a drive present, but asks for disc with drivers on but as no CD is supplied,will not work. looking in device Manager usb shows an ? mark.contacting Mesh help line, they think it is a motherboard problem. PS one other card reader wont work also, but printer,scanner,phone, Flash drive all work ok.
Any idias please gang.

  Devil Fish 20:12 11 Sep 2007

if you are using xp sp2 try updating your usb driver

an external usb drive should not need drivers unless you are using a pre xp operating system

  martin p 22:39 11 Sep 2007

I am using XP sp2, but the manufacturing website says, there are no drivers for there device,

but using a multi card reader this won`t work either.

Strange anything else will work , have tried different usb sockets to no avail.

  Devil Fish 23:14 11 Sep 2007

have you tried updating your usb driver go to the device manager where the question mark is click on the cross next to it and expand it right click on item in sub menu then click update drivers

it may be your devices are looking for usb 2 and the drivers for usb 2 are either corrupt or not installed

  Acx 23:39 11 Sep 2007

When I plug in an external usb drive Xp uses the following driver


When it asks for a disk with drivers on try and browse to this driver.

  martin p 23:49 11 Sep 2007

thanks guys will now have to try this tomorrow, thank you all .Martin

  martin p 19:53 12 Sep 2007


Have tried that, to no avail, even just tried a 1 gig flash drive - perfect.
Seem some drives and USB type things work others don`t ?.

Tried updating drivers for the USB ports, OK anyway.

Any other idia`s please

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?