problems with usb2.0 storage device

  elmerfudge 19:45 21 Jul 2005

I run a Seagate HD in a caddy connected via USB2.0. Has been working well for months and then threw wobbly. I have run numerous checks from many different sources - HD ok. Have reformatted and reloaded. I switch it on - red light turns to green but nothing in Computer Manager to reflect the HD. Light then turns back to red. Device manager shows device connected and no problems. I have to switch it off and then back on before I get the green light to stay on and Computer Manager showing the 2 partitions I have on the device.
Any advice would be much appreciated.

  Greengage 12:08 22 Jul 2005

I have s similar problem, but with Safecom caddie & Maxtor HD. I have a powered USB 2 hub but whenever I turn on nothing shows and after two/three efforts of unplugging the USB2 lead & re-plugging into PC, I finally get it to come up.

  elmerfudge 15:22 22 Jul 2005

Tks for response. Very interesting. Let's hope someone out there can come up with resolution or at least what the cause is.

  Fruit Bat /\0/\ 15:35 22 Jul 2005

go into device manager and uninstall all the USB devices (root hubs) etc.

reboot the PC and let XP find new hardware and reinstall all the ports and harddrive.

  elmerfudge 19:40 22 Jul 2005

Tks Fruitbat. Did as you suggested, twice, but unfortunately to no avail. At current attempt I had to switch it on and off 4 times to get it to work. At one point according to Device Manager I received message "Device cannot start (Code 10)" and after searching various forums is a very general term. I am going to try just pulling power cord rather than switching it off. It's either that or it goes out of the window!!

  woodchip 19:49 22 Jul 2005

go to device manager and uninstall the enhanced usb controller and restart then try hard drive after windows resets the controller

  Eastender 01:20 23 Jul 2005

I suppose you have tried a different USB lead?

  elmerfudge 06:50 23 Jul 2005

Tks. Tried the enhanced controller bit and also bought a new lead so now have a spare one!!. However, I did pull the mains lead rather than using the switch and today I plugged in the mains lead and lo! and behold! the HD worked perfectly first time. To a non technical person like me this would indicate a fault in the power supply through the switch on the caddy but the red light suggested power was okay. It is a self powered caddy so I am going to unplug and then plug back in the transformer and see what happens. I will keep youse posted.

  elmerfudge 19:02 25 Jul 2005

Pulling the mains plug on the caddy did not resolve the problem. Did various scans etc, again and no problems with discs. Got an Event 51 log entry which according to MS all I could do was change (ditch!!) the device. I have now resorted to pulling the mains plug from the wall. I have done this several times and the HD has worked first time every time. I'm going to call it quits for now until it bugs me and then I'll try using the switch again. Computers being computers it will probably be fine!!! Tks for all assistance.

  Jdoki 20:12 25 Jul 2005

Have you tried a different USB port on your PC?

If you disconnct the USB cable from the PC when the red light is on, and plug it in again does Windows detect the device?

Any chance you you try the device on another PC?

Just trying to eleminiate the potential for the USB port or controller in your PC being dodgy.

Code 10 normally points towards device drivers, so I'm unsure why flicking the power would get the thing working!

Are all your other USB devices working OK?

  elmerfudge 15:40 26 Jul 2005

Have tried various USB Ports and just about every variation I can think of. I haven't tried it on another PC as yet but so far it is working perfectly except I don't use the mains switch on the caddy. I just pull plug from mains. The only thing this does is power down the Transformer rather than the caddy directly. I wonder!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Amazon Echo: What’s the best Alexa speaker?

Kano Computer Kit Complete review: A fun DIY 'laptop' that teaches kids to code

Best pro photo editors for Mac 2018

TV & streaming : comment regarder les Jeux olympiques d’hiver 2018 ?