Problems starting 2nd hand Olivetti Pentium 133MHz

  Stoned 21:57 04 Aug 2003

Have purchased cheap second hand computer for my daughter.
On switching on shows:
"American Megatrends AMIBIOS (etc)
Resident Diagnostic Rev. 1.24 -0
32384 KB OK

Then two beeps
"A Drive Error
Press F1 to resume"
Again 2 beeps
F1 pressed shows:
"Main Processor:Pentium (tm)
Maths Processor:Built In
Floppy Drive A: 1.44 MB 3.5"
(Etc Etc)
Pipeline Burst SRAM Type detected
Boot Failure
Insert boot diskette in A:"

I have tried inserting my Windows 95 boot disk (I understand 95 is installed)to no avail.
I have tried 'delete' and 'F1' when loading, but cannot 'break in'.

Any suggestions please?

  MichelleC 09:02 05 Aug 2003

2 beeps on AMI bios means Parity Circuit Failure. Are you saying you can't get into bios (try Ctrl, Alt, Esc depressed)?

  alcudia 09:53 05 Aug 2003

I used to have a Olivetti P120 a while ago. This had an Ami bios. On this machine the bios was accessed via the space bar.

  DieSse 10:17 05 Aug 2003

If it says "A Drive error" - then this means a faulty floppy drive - so it's unlikely you will be able to use it.

However, the fact that it also cannot boot up to the hard drive, could mean a faulty battery.

If you manage to get into the BIOS, then check all the settings, for the variuos drives. If they are all wrong, it's likely the battery has failed. you should be able to rest the BIOS for this bootup, and see if everything works OK. If it does, then a new battery is required. Note that all the settings will be lost again when the system is switched off.

Howeever it could also just mean the floppy drive is faulty. Have a look and see that the cables are correctly attached to it - then try another drive (they're very nexpensive).

  ardvarc 11:38 05 Aug 2003

Is it a Olivetti Xana P133 Desktop by any chance. I had one in 1997 and it came with a restore CD which I still have. Worth doing what DieSse suggests.

  Stoned 21:57 07 Aug 2003

alcudia: your information that bios was accessed by spacebar proved correct, thanks.

DieSse:a/ floppy drive was incorrectly connected, now accesses second screen after simply saying 'wait'. Final remark: Drive not ready. Insert Boot diskette.
b/ battery seems ok, clock correct, (well an hour out), and after changing order of access and restarting, new settings remained.

ardvac: It is an Olivetti Tinsl/II
Worth my trying your restore disk?

As the floppy was incorrectly connected, the hardrive might also be.
BIOS is something I have only recently started 'tampering, with. Any further suggestions would be appreciated.

  DieSse 23:41 07 Aug 2003

Drive not ready says the hard drive is not ready - that could mean it's failed, or the connections are wrong (again).

The flat ribbon cable must be connected the right way round - the edge with the red stripe should be on the pin 1 end of the connector - on the drive this is next to the poer connector - on the motherboard you will have to look.

If the cable's correct (and assuming the power cable is attached) - then the drive is not working correctly. It could have been wrongly set in the BIOS - with an old BIOS ñook for an auto detection setting - if it can't even be detected, then it's probably not spinning.

That's pretty terminal - though sometimes you can "kick-start" an old drive by slapping it with the palmof your hand, when the power is on it (on the top - don't touch the electronics!)

If by chance this works - do several power-up/power-down squences (10-20), one after the other. But you can assume pretty safely that the drive has passed it's sell-by date.

  ardvarc 07:45 08 Aug 2003

Mine had a 1.5Gig HDD, 16 or 32Mgb EDO RAM, WIN 95, WIN95 Plus, MS WORKS, MS Phone/Answerphone and it was a great machine. I bought it to learn on and I only knew how to switch it on when it was installed. Never had the case open so I can't help, I didn't know how in those days. Some might say I still don't.

I will try and do a bit of digging on your model as the restore disk has a few code numbers on it. It wasn't just for the Xana P133.


  alcudia 08:37 08 Aug 2003

Thanks ardvarc. I had a Xana p120 and I learnt a great deal from it. 8mb ram (originally) and 1gb HDD. Had the case open quite often. I had forgotten all about MS Phone. What happened to it? Also had all the other progs you mention. There was something else as well, I thing it was to do with talk or speak, something like that. The important thing was it never let me down and was still working when I gave it away in 2000. Those were the days.

  ardvarc 08:52 08 Aug 2003

Yes I remember it. I think it was a voice recognition programme that you had to train through the microphone and it was supposed to open programmes, type documents in Works using speech recognition. Never did get the hang of it. They were ahead of their time. I did use MS Phone a lot especially as a answerphone. Mine went to s-i-l then he passed it on to his niece. Olivetti sent me a spare restore CD but it was me giving wrong commands restoring it.

  alcudia 10:56 08 Aug 2003

You are right, I have remembered it was called MS Voice. I could speak into the mike something like Run Word and it would. As you say it was ahead of its time.
Ah! memories.
But all this dosn't help our friend Stoned.
Like someone has already mentioned, I think the hard drive has had it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review: Hands-on

How to add texture to hand-drawn artworks

Best free iPad apps 2018

Comment créer un compte PayPal pour payer en ligne ?