Problems installing network card in Win 98

  Unplugged 15:18 30 May 2003

I am trying to install a Linksys Etherfast LNE100TX network card on a PCI slot in my Celeron 433, Win 98 SE PC. I have had various problems and have been working on this on and off for days, rats! I have re-installed windows, deleted and reinstalled the device many times, removed and deleted other modems and associated software and torn out the last remaining strand of hair from my shiny head.

The latest - when booted, windows detects the new device, installs the drivers and during this time asks me to insert the Windows 98 SE CD-ROM, then it says that it cannot find file “services”. I have searched the Win 98 SE CD-ROM, there is no such file on it nor is it on the Linksys CD-ROM. The Ethernet card does not get installed properly, ie has faults, is not recognised as a Network adapter.

The card suppliers (Linksys), who in fairness have been pretty helpful about the raft of problems I have had , tell me the problems are not down to them, i.e. this is a Windows issue L.

Please, does anyone know what this file “services” is, and where I might get hold of it?

With thanks in advance, Unplugged

  AndySD 15:51 30 May 2003

Did you do a clean install (format then install)

Try using the System File Checker...

Put your windows CD into the CD ROM and hold the shift key (the one with arrow pointing up, just above the Ctrl key on the left of your keyboard). Holding shift for a few seconds will stop the Windows CD from auto running, but the drive will still spin up to read the disk then spin back down again. Once it has spun down you can release the shift key.
Now click Start, and then click Run. In the Run command line type the letters SFC then click OK. This will launch the System File Checker that will sift through your Windows System Files looking for anything that has been replaced by an older version of the one it got from the Windows install.

If it finds any files that have been altered it will tell you and will prompt you on whether you would like to replace the files. If you would, the Windows CD is already in the CD ROM ready for your PC to read the files from, so just follow the prompts.

  Unplugged 16:29 30 May 2003

Thanks for your response.

I did not do a clean install (did not wish to scrub all the useful stuff).

I have tried SFC it came up with one file that may be corrupted, "setupx.dll".

I selected option to restore the file. The restore from location comes up with "C:/windows/system/precopy" it does not find the file there, nor does it find it when I point it at the D: drive.

It appears to want the correct path in its entirety. I am just learning about this, but it seems that Windows compresses system files into .cab files(folders?) for instrallation. Am I right in thinking that if I can track down the correct cab file, I can restore the file from there? If so the problem is to find out what files are compressed into the cab files - any suggestions?.

Does this sound right???

Thanks, unplugged

  AndySD 16:38 30 May 2003

Ok dont worry about setupx.dll its a known glitch.

Yes the services folder may well be in a cab file. I will look to see if I can find out which one.

  mrdsgs 16:45 30 May 2003

have you tried a different pci slot

it may be an irq conflict

  AndySD 16:51 30 May 2003

click here

But I am wondering if its the system or system32 folder in the windows folder on your hard drive it cant find... have a look and make sure they are not read only.

  Unplugged 18:03 30 May 2003


Thanks for suggestion I have tried it out. I still got the same message on install, requesting the "services" file. I skipped this and the device 'appears' to have installed with no errors - I have checked resources under device manager and it states there are no conflicts!

Unfortunately the device still does not work as expected but at least the system is not crashing out.

Thanks for your help - I have looked as suggested:

Nothing in system or system32 folder BUT in c:/windows there is a "services" file its attributes are 'archive'. Also in c:/mydocuments/my webs/_vti_pvt and in c:/webshare/wwwroot/vti_pvt tere are files called "services". The properties for the last two are type: 'SpeedDial'. These are both 'archive' as well and say they were access 30 May 2003.

Cannot find help on the meaning of the archive attribute - but will try taking it off to see if this has any effect and will let you know.

  Unplugged 18:43 30 May 2003

I removed the hardware and rebooted, plug and play installed the drivers and then asked for Win 98SE CD as per usual. This time I pointed it at C:/windows, where there is a file called "services" and then ......

Screen went blank ... screen went blue:
'A fatal exception 00 has occurred at 0028:C028A1BD in VXD NDIS(04) + 0008A4D. etc. etc.' Rats!

I reboot - it comes up in safe mode. I open a bottle of wine.

Curiously the adapter appears to be installed without errors, but under properties/resources it says 'this device isn't using any resources because it is not currently enabled or has a problem' (too true). I think I'll try another re-boot - it won't come up in normal mode! sip, sip, Force power off, safe mode, remove hardware and back to square one.

What do you think? Is this a lost cause or what? Grateful for any suggestions!

Regards, unplugged.

  AndySD 07:34 31 May 2003

Go down pc world and buy another make of NIC... they have them for under a tenner.

  AndySD 07:34 31 May 2003

Go down pc world and buy another make of NIC... they have them for under a tenner.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Inside the iMac Pro - Apple's most powerful Mac yet

iMac Pro release date, UK price & specs

Comment nettoyer Windows et optimiser son PC gratuitement ?