problems with installing isp in XP

  palinka 09:20 03 Oct 2003

A friend bought a new laptop (his 1st computer) running XP. I've been trying to install an isp for him from a disk. Installed Tiscali OK and sent one email. Then all went pear shaped - error message "incorrect password or user name..." kind of message.
When we tried again got other error messages eg "Instruction at 0x77f5215c referenced memory at 0x00804f38. The memory could not be written. Click on OK to terminate the program".
and another (don't have the details to hand)that said close all programs, computer would be shut down in X seconds. then follows a count down of that time and it shuts down. Any suggestions, please. Is this a hardware fault - computer is only 4 months old - or is it something else? The friend is a great fiddle-fingers, inclined to click on buttons that he shouldn't touch.

  Jester2K II 09:31 03 Oct 2003

computer would be shut down in X seconds. then follows a count down of that time and it shuts down.

Does it mention Remote Procedure Call (RPC)??

  Jester2K II 09:40 03 Oct 2003

If so sounds like you've picked up MSBlaster or a varient.

click here

  palinka 10:22 03 Oct 2003

Jester2K II, thanks for your response. I can't remember if there was a referece to RPC, but I'm fairly certain I would have noticed if there was. i haven't got his computer to hand at the moment so can't check. As I was typing my original message I did begin to wonder about a virus; but is it poss to pick up Blaster or any other worm if he's never (until yesterday)had an internet connection and the only disks loaded have been OEMs for MS Works. No floppies or anything else as far as I know.

  MAJ 10:56 03 Oct 2003

As Jester2K II says, palinka, it certainly sounds like Blaster and yes, it could have been contracted by the mere fact that the PC was conected to the internet. Download Stinger click here but before running it, disable System Restore to delete any restore points, run Stinger and when given the all clear, re-activate System Restore.

  Jester2K II 11:01 03 Oct 2003

It takes 30 seconds to pick it up once connected. It doesn't arrive via e-mail it's sent DIRECTLY to your PC.

You said "Installed Tiscali OK and sent one email. " that would have been MORE than enough time.

Follow my thread above and then get Free Anti Virus on that PC click here

  palinka 11:41 03 Oct 2003

he already has Norton AV. I downloaded all the updates and ran a partial scan before I ran out of time (there is life away from computers!), but his Norton was 4 months out of date, 'cos that's when he bought the computer, and without an isp he'd never connected to get updates. So I had to install one as a first step. Aarrrgh!
I'm away now for the rest of today, but I'll try to sort him out over the weekend.It does sound like a virus.
Many thanks for your advice.

  Jester2K II 11:43 03 Oct 2003

Lets us know. Good luck.

  palinka 16:57 04 Oct 2003

Hi folks, following your helpful instructions I ran a complete scan with Norton, which said it had detected w.32.Welchia. I removed System restore, applied patch that Jester2K II referred to; ran Stinger. Stinger said it had found and deleted Nachi. But Norton still says I have the W32. Welchia Worm on the computer. Where do I go from here? Seem to recall a thread here about similar dilemma but can't find it now.

  palinka 18:18 04 Oct 2003


  Irishman 18:24 04 Oct 2003

Try deleting it in safe mode

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Nokia 6 (2018) review

iPad 9.7in (2018) review

Comment retrouver son code Wifi ?