Hot Topics

Problems Installing AMD Software Error 1603

  RobCharles1981 21:43 21 Dec 2018
Locked

Hi all

I'm having trouble installing the latest AMD Drivers for my Graphics Card an R9 390 I'm using Windows 7 64bit.

Like in the usual way I would use the AMD Cleanup too to remove the driver and restart windows before installing the new driver which has always worked.

But when I try to re-install the drivers I get an error 1603.

Its saying the solution that I need to run the "​Run the Windows Deployment Image Servicing and Management"

It says "Error 87" as its not recognized in this context"

And Then it says to run sfc/scannow When I run that in CMD via "Admin"

It says "It found corrupt files but was unable to fix some of them"

Can anyone help? Thanks Rob

  LV426 12:25 22 Dec 2018

I take it you have run diskcheck as in scan for errors under tools, Can you go back with system restore, are they 32 bit drivers ? der I had to ask, was it not broke and you tried to fix it.

  RobCharles1981 18:47 22 Dec 2018

Done every thing known to man, System Restore keeps turning itself off after a period of time which is a real pain so no its off.

Ummm no they are not 32bit drivers they are 64bit hence Windows 7 64bit?

Having drivers updated is always a good port of call as improvements are made all of the time.

I've done this for years and in the same way to clean install with no problems whatseoever.

  RobCharles1981 22:00 22 Dec 2018

Hi Rdave13

I'm trawlling the links on google and they do the same solutions as I've tried! :-S

  RobCharles1981 00:25 23 Dec 2018

Thanks Rdave,

I may consider sticking Windows 10 on I think.

Windows 7 has been solid as rock always worked tbqh, will do more digging to see what else I can come up with this snag.

  howard64 09:59 23 Dec 2018

have you gone into device manager and uninstalled the graphic card drivers? after a restart it then sets up automatically.

  RobCharles1981 15:12 23 Dec 2018

When I do the "SFC" in CMD under admin It says this: "Windows Resource Protection Found Corrupt Files but was unable to fix some of them"

Out of interest where is the download version for the "Microsoft Visual C++ Redistributable files for Windows 7?

  RobCharles1981 15:13 23 Dec 2018

Hi Howard -

Yep I have and even used the AMD Removal Utility to completely rid of all AMD Software and attempted to have another go of installing but still the same problem! :-S

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Realme X50 Pro 5G confirmed: Release date, price & specs

How do you brand real estate for Generation Rent?

Best free iPhone apps

iPad et iPhone : comment installer Microsoft Office gratuitement ?