Problems with installation of new hardware

  Europa 02:00 14 Oct 2006

I have tried to install a plug and play steering wheel (Logic3 PC Topdrive GT4)a couple of times but every time it says that there was an error during installation and that the hardware might not work properly. It doesn't work at all (I am trying to use it with need for speed 3). I am pretty sure that the first time I tried to install the device, a window opened and said that the firewall was blocking the new hardware, and ask me if I wanted to unblock it, which I did. Is there a conflict with this device and the window firewall?
Last time I tried to uninstall the device, it said that I couldn't do it with the uninstall file and I had to do it with the device manager, I just restaured the lot to an earlier time, it is not listed anymore in the games controllers' list, would that suffice to uninstall everything?
How do I install the steering wheel for it to work properly?

  ICF 06:40 14 Oct 2006

According to the SpectraVideo website no addition drivers are needed and it should be plug and play.I firewall is for protecting an internet connection and should not be connected with installing a joystick or gaming steering wheel.Try installing it again then going to window update and there could be an updated driver for it

  Europa 14:28 14 Oct 2006

I have uninstalled the steering wheel and the game, reinstalled the steering wheel then checked if there was any update for drivers on the windows update website. No update existing for this device, but when I reinstalled it it didn't say anymore that it may not work properly , and I have calibrated the device, everything on it is working allright as far as I know. Is it possible that the game does not support a steering wheel as a controller ? The game is working fine with my joystick.
What the Firewall was blocking was the game (Need for Speed III). It says : Windows Firewall has blocked this program from accepting connections from the Internet or a network.
I have another problem with another game called Rollcage II. After installing it, I try to reach the menu but it goes back to Windows before it reached the menu, why is it doing that? I did uninstall and install it a couple of times, and it still doing the same thing. I do not understand here as that game was working perfectly on my old computer, which was running Window Me. It would be a shame if I could not play with my older games, sayng that it's strange because some other of my older games are working properly.
Another thing, why is the icon of the Need for Speed game showing in my computer, under devices with removable storages?

  ICF 18:01 14 Oct 2006

Do you have an external drive of any kind?

  Europa 20:37 14 Oct 2006


  Europa 20:48 14 Oct 2006

What I think happens is that I've got 3 items listed under Devices with Removable Storage : 3 1/2 floppy, DVD/CD-RW Drive and DVD-RW Drive. The Game icon replace the samsung DVD/CD-RW drive.
I have restaured the computer again and the icon vanished. I have no idea why it would do that.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Fold review: Hands-on

How to create a robot painting in Photoshop

iMac 21.5in (2019) review

Comment faire pivoter une vidéo ?