Problems with card reader

  Peter Lanky 10:00 14 Feb 2010

I have a Sweex internal card reader which has worked OK in the past. I have recently swapped motherboards and reinstalled W7 home premium, and after installation, the reader worked OK. Now I want to get some data off a compact flash card, and it is not recognised. I can't see it being the wiring because if I plug in a pen drive to the USB slots on the reader, that works fine. I also have a USB card reader, and the CF card is not being recognised in this either. Too much coincidence.

In control panel, the USB card reader shows as not working, with the message 'This device cannot start Code 10'. This is the same if it is plugged into the card reader USB or any other USB. Whe I try to uninstall the device, the uninstaller hangs,and I have to take out the card reader.

  Fruit Bat /\0/\ 10:43 14 Feb 2010

In the device Properties dialog box, click the Driver tab, and then click Update Driver to start the Hardware Update Wizard. Follow the instructions to update the driver.

You may be prompted to provide the path of the driver. Windows may have the driver built-in, or may still have the driver files installed from the last time that you set up the device. If you are asked for the driver and you do not have it, you can try to download the latest driver from the hardware vendor’s Web site.

sweex drivers click here

  Peter Lanky 14:47 14 Feb 2010

I tried that, but was told I have the best driver. Sweex doesn't have a driver.

As we all know computers are fickle, and after doing nothing other than putting cards, readers and USB devices in and out, the integrated card reader suddenly started working again about an hour after this post, and now shows each slot as a new drive in My Computer, as it did before.

The USB Compact Flash reader is another matter though. It shows in device manager as both a hard drive (??) and as a USB mass storage device, and also shows in 'pronters and devices' as a device, but as unavailable. I'm beginning to think it's goosed, so it's back to the Amazon Marketplace dealer I think.

  woodchip 14:59 14 Feb 2010

as its connected internal to usb, uninstall all usb in device manager then restart computer let windows reconfigure usb before trying

  Peter Lanky 19:13 14 Feb 2010

USB now all working, but my 8GB card is not recognised if used in the USB CF reader. It is recognised if I use the CF slot on the internal card reader, and smaller cards are recognised in the USB card reader.

The thing is, this was not a problem before I changed my motherboard.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?