Problems with Ancestry and Google Chrome

  Border View 10:56 11 Jul 2013

I have used Google Chrome for a number of years and never had any problems logging into Ancestry. Since about June however when I click on Ancestry I get their home page but nothing happens when I try to log in. No problem if I use IE.

I would prefer to use Chrome to visit Ancestry. Can anyone please suggest what might be going wrong.

Thank you.

  Border View 14:11 11 Jul 2013

Has anyone else had similar problems with other sites?

  T0SH 14:39 11 Jul 2013

If this is the site you are referring to ""

I have just opened it in Chrome without any problem

Cheers HC

  spuds 14:52 11 Jul 2013

I am not saying its the answer, but I have had problems with my bank accepting IE as its main browser for security reasons. Chrome and Firefox use to work fine, but not any longer. In this case I have to use IE, I am being given little option on the matter?.

Do you require any form of security (https) to login in to the website and perhaps your account?.

  Border View 17:20 11 Jul 2013

Hi Tosh - I can open the home page of but it ignores my click on Log In. If I open Ancestry on IE when I click on Log In I get a drop down box to enter details. This does not happen in Chrome.

Spuds - I am not aware of a security log in. Yes I have to pay an annual subscription but once paid you can normally log in without problem. Its just a bind having to open IE to log onto the web site.

  alanrwood 18:56 11 Jul 2013

Just logged in to Ancestry via Chrome without any problem.

  Border View 22:36 11 Jul 2013

This is what I cannot understand. I feel it must be my settings but dont know what they should be to allow me to log in to Ancestry via Chrome.

  HenryF75 08:13 12 Jul 2013

I am having similar problems with some software not connecting to web pages in chrome and have been advised it is a problem with Chrome not responding properly to the Windows API function ShellExecute! A web search on Chrome+win8+shellexecute shows the extent of the problem. The only answer at this time is to set IE as your default browser so links open pages in IE This happens mostly with Windows 8 desktop so may not be your problem.

  Border View 09:55 12 Jul 2013

Henry F75 - thanks for responding. I should have mentioned that I use Windows 7 - don't know if this makes a difference.

  Border View 10:16 12 Jul 2013

Problem solved. I telephoned Ancestry and they took me through the steps to clear Chrome history and cache. Did the trick.

Thank you all for responding. Will do the green tick.

  Border View 16:14 12 Jul 2013

Spoke too soon. Back to square one. Been on the telephone again, because next time I tried to access Ancestry it had not retained my sign in. Tried with same result as before, nothing happens when I click on the sign in button. Uninstalled Google Chrome and reinstalled. Still no luck. Telephone Ancestry and their best advice was to use Internet Explorer where it does work.

At a loss.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Explore Milton Glaser's iconic poster designs from the 1960s to present, including Bob Dylan, I…

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts