Problems after conversion from FAT32 to NFTS

  Dipso 09:54 24 Jan 2009

I hope someone can advise.

I recently converted my external HD from FAT32 to NFTS to allow me to move over some >4GB files. The conversion was successful and I have had access to the drive and the content since the conversion.

Last night I tried to access the drive and it is now coming up as FAT32 again and I can't see any data/files although the drive is showing as only 1.88GB space remaining, it's a 500GB drive?

I ran chkdsk which was reporting "Bad links in chain or cluster 12345 etc - corrected. I left chkdsk running over night and this morning it asked if I wanted to convert the data to files so I answered yes. I performed the task then came back with "Insufficient disk space" and reverted to the command prompt. I am no nearer as I still can't access the data.

What should I try next? Is all lost?

  Technotiger 09:58 24 Jan 2009

Run the conversion again from FAT to NTFS - doing so, does not lose any data.

  Dipso 10:01 24 Jan 2009

OK will try that later and report back. I did think about doing that but thought I would ask first before I possibly made things worse.

Cheers Technotiger.

  Dipso 23:25 24 Jan 2009

I tried the conversion again and got the message that "conversion to NFTS not available". I tried once more and got the same message. I attempted to convert to FAT32 to see what would happen and go the message that the drive was already FAT32.

I tried chkdsk again via My Computer > Properties> Tools and selecting Auto fix file and system errors and scan for and attempt recovery of bad sectors but got the exclusive access required message and that I should reboot, which I did but chkdsk didn't start. I tried again and the same happened. I tried Scan for bad sectors on it's own which got stuck at Phase 1.

I downloaded Seatools to see if that would help my predicament but found I am unable to run many of the tests as I get "test unavailable" messages. The short generic test passes so I am running the Long generic test now which advises I back up...bit late for that!

  Stuartli 23:47 24 Jan 2009


click here

There is a wealth of information on this site about NFTS and FAT32.

  Dipso 23:55 24 Jan 2009

If you had read my initial post you would have seen that I successfully converted my drive to NFTS, the problems I am now having are post conversion.

  €dstowe 07:17 25 Jan 2009

You might try a low level format (fill with zeros)- the procedure is part of Seatools, I think.

If this fails and as you cannot access the manufacturers diagnostic procedures it is time that the manufacturer had a look at the drive - there is something deeply wrong with it.

  Dipso 10:07 25 Jan 2009

OK, no joy from the Long generic test with Seatools. I had one more try with Error checking via Windows but got this click here which is pretty much what I got the last time I tried it.

Will try the low level format and see if that works. If this fails and the manufacxturer is the only option left, is there any chance they could retrieve the data or should I just attempt a full format (if that is an option), call it quits and say bye bye to the data?

  €dstowe 10:27 25 Jan 2009

I think you'll have to be prepared to say goodbye.

I've had two WD MyBook drives fail on me in a similar fashion to what you're experiencing. In the end, there was nothing I could make them respond to at all.

WD were very good at replacing the items and nothing was lost as I always have backups of everything.

  Dipso 19:18 25 Jan 2009

Well I said my goodbyes and went for a full format. The drive came back with a clean bill of health. It wouldn't have mattered too much if it hadn't as it was still within the 3 year warranty, I only bought it in October 08, but obviously the data was lost. Fortunately the stuff that was most important was backed up so no great loss. I won't fill it up again until I'm sure I don't get a repeat of the problem.

Thanks to Technotiger and €dstowe for your help.


  Technotiger 19:23 25 Jan 2009

Thanks for your feedback - afraid I was not much help, but at least all was not lost.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique