Problem with XP Fast User Switching

  User-9A919F67-6ADE-4BFB-8B35A0F56CB2F7D6 11:02 08 Dec 2003

A few weeks ago I noticed that when one of my kids tried to log off (with Switch User) of their limited account, that instead of going back to the Welcome Screen, they were instead taken to a black screen with no mouse pointer or anything else. The only way to get round this was to reset the system. This has now started happening more and more often, but again only from Limited Accounts (so far?).

I have tried an "sfc /scannow", a system restore back as far as I can, and a full virus scan. Nothing cures this problem. I have now switched off Fast User Switching and the black screens have stopped. The only problem is that I want my system to be able to use it.

When they log off with Switch User, it comes up saying "Logging Off" then "Saving Settings" as usual. The screen then goes black and stays that way. I have tried leaving the system like this for 20-30 minutes but it doesn't reset itself. During the 20-30 minutes I notice that there is occasional disk activity, but obviously I can't see what. The Event Viewer doesn't show anything.

My system is using XP Home with SP 1 and is up-to-date with all critical updates. I have 512 Mb of memory.

Anybody got any ideas?

  JIM 11:46 08 Dec 2003

try a reset of the other accounts to unlimited,to see if it may cure the problem.then after a reboot check out Fast User Switching.Rem,to replace tick in fast user box.

  spikeychris 12:13 08 Dec 2003

Common problem, XP can loose fast user switching, if JIM's solution fails then Open the registry and find the key below. You may need to create the key if it does not already exist.

Create a new DWORD value, or modify the existing value, called 'AllowMultipleTSSessions' (exactly as printed) and edit the value according
to the settings below.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Value Name: AllowMultipleTSSessions

Data Type: REG_DWORD (DWORD Value)

Value Data: (0 = Disable Fast User Switching, 1= Enable)


A bit of clarification seems to be called for.

All the accounts except mine are limited. I have 1 admin account and 4 limited accounts.

Fast User Switching is available (and always has been), but when enabled it is causing the problem (occasionally) that when users select "Start | Log Off | Switch User", instead of being taken back to the Welcome Screen, they just get a black screen and cant get out of it. This works fine about 9 times out of 10.

spikeychris, the registry key is there and it has a value of 1, which confirms that Fast User Switching is enabled.

  spikeychris 15:15 08 Dec 2003

FUS reacts badly to some progs, have you installed anything lately? Go to "administrative tools" menu and select "Service"
find the service that says "Fast User Switching
Compatibility" right click on it and select "Automatic"

click here for a shutdown guide.

I honestly cant think of anything that I've installed lately. Do you know of any particular programs that have this affect? The main programs I have running are ZoneAlarm Free (latest version), AVG 6 (latest def file) and Messenger 6.1 (latest build). All of these were updated in the last month so I guess it could be one of those.

Checked in Service and FUS was set to Manual. Have now changed it to Automatic as you requested.

  spikeychris 17:15 08 Dec 2003

Firewalls and AV's are the main culprits. Just before you switch use Ctrl Alt Del to see whats running then turn each one off until you see whats causing the problem. Pain in the wotsit but at least it will break it down.

OK, I'll try each one in turn and let you know.

Thanks for all your help.

I stopped ZoneAlarm from automatically loading on startup, and the problem went away.

The system has been up for 3 days now, with the same amount of usage as before, and no black screens have appeared. The system starts quicker, and the internet is faster.

There have been other threads running as to whether a firewall should be used or not. I'm going to try running without one, at least until a new version of ZoneAlarm is released. My AV is updated daily and I have AdAware and SpyBot installed.

A short while after writing my last thred the problem re-appeared.

I then spent many weeks removing different applications and chaging system settings to try and cure the problem.

At the start of last week I happened upon a site where somebody had had a similar problem. They found that the cause was having their screen resolution set to a value that the graphics card wasn't happy with.

Out of frustration more than anything I changed my screen resolution from 1158 x 768 to 1280 x 720. Since then I haven't had a single blank screen.

Thought I would post this in case anybody else has the same problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Comment utiliser Live Photos ?