Problem With Windows 7 Updates 'Uninstalling' Wireless Adaptor

  Chris Webster 20:44 22 Mar 2012

Hi all,

My friends laptop – Windows 7 x64 – has a rather strange problem that has stumped me.

Every time there are any ‘Patch Tuesday’ updates they download and install as they should, but, after a restart the wireless connection ‘disappears’. When it restarts it’s as if the laptop isn’t wireless enabled.

The laptop was auto downloading / installing as it should do without any problems up until 2 months ago.

When you look in Device Manager > Network Adaptors there is the yellow triangle / ! symbol next to the WiFi adaptor entry.

The only way I can get the wireless working again is to do a ‘recovery’ to just before the updates were installed, then go to Windows updates and ‘hide’ all the updates so they don’t re-download.

I don’t know if this is related to the above problem but ‘W7 Service Pack 1’ will not install either. It downloads and starts to install then a message comes up saying ‘failed to install’ and another message saying that it cannot install because something is missing ( I can’t remember the exact wording ) I followed the link the error message gave and downloaded / installed the ‘System Update Readiness Tool for Windows 7 for x64’ and then tried to install W7 SP1 again but it still failed and the same message as before came up.

Does anyone have any ideas what’s going on and how I can resolve these problems as I have had to ‘hide’ 2 months worth of Windows updates up to now, plus SP1 isn't installed.

Any help would be gratefully received,

Regards, Chris.

  birdface 21:44 22 Mar 2012

Switch off automatic updates and download manually.When you update manually and you get the same update for the Wireless connection just click on it and a box will open underneath just tick the box so that it does not show the update again.

Or just roll back the driver if you can.

  Chris Webster 21:57 22 Mar 2012

Hi buteman,

I've tried manually downloading the windows updates one by one and it seems that no matter what KB number update it is they all 'uninstall' the wireless adaptor.

There are now 2 months worth of updates plus SP1 'hidden'

Does sfc /scannow work on W7 and would it be worth doing?

Regards, Chris.

  robin_x 22:10 22 Mar 2012

Yes sfc /scannow will run. (Run As Admin)

I've just had two computers it failed on though.

Fixed one by a repair install. Which buggered up sharing and printers.

Wifi Probs are a pain in the arse, Use a network cat5 cable to router if posibles or buy a spare 'n' dongle.

Plenty low profile under a fiver amazon ebuyer ebay etc

I just got this from Guernsey, 36hrs delivery, seems alright.

  birdface 22:16 22 Mar 2012

Yes sfc /scannow works and you don't need the W/7 CD it works without it.

I used to get an audio update every month which would stop the audio on the computer and it was just a matter of rolling back the driver for it plus it was easy to stop it downloading with the automatic updates turned off.

  Chris Webster 22:26 22 Mar 2012

Hi robinofloxley,

I don't need a dongle, it's a Windows 7 laptop so it's wireless as 'standard'

Regards, Chris.

  Chris Webster 22:29 22 Mar 2012


The updates aren't for the wireless drivers, they are the Windows critical / recommended / optional updates.

Even W7 Service Pack 1 will not install.

Regards, Chris.

  birdface 22:46 22 Mar 2012

Not sure why but service pack 1 would not install for me using windows updates I had to search Microsoft and ended up finding one that would install.

If you have attempted to install it I would run Windows Disc clean up to remove it again as it takes up about 400mb of space.

Not sure why it will not download on some computers but will on others.

  Chris Webster 23:36 24 Mar 2012

I tried to run sfc /scannow from the command prompt but it said I had to be logged in as an administrator. My friend whos laptop it is is the only account on it and it says it's set up as an admin account.

After the wireless problems I plugged the laptop in using an ethernet cable and downloaded W7 SP1 again through Windows Update. After it installed and rebooted a window came up saying 'installation failed - ethernet not found'. But the ethernet was plugged in and connected as soon as the laptop rebooted.

I then went to the Microsoft site and downloaded and saved the full 903MB SP1 file. After it installed and rebooted a window again came up saying ' installation not successful - element not found'.

Anymore help and advice gratefully received.

Regards, Chris.

  rdave13 00:27 25 Mar 2012

If you have Trusteer Rapport installed try uninstalling it, rebooting and use Windows update to install SP1. As far as sfc is concerned, type cmd in the search bar, then in the list right click CMD and select ' Run as Administrator'.

  birdface 09:32 25 Mar 2012

As rdave13 says run as administrator.

SP1 it took me nearly 3 months to come up with a fix for SP1 download but unfortunately I no longer can find the site that I used.

Maybe contact Microsoft and see if they can give you a fix for it.

Googled but no doubt you have already tried that.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Best Keyboards for Designers & Artists

What to ask Siri on the HomePod

Meilleurs VPN (2018)