problem with western digital external drive

  Ranger 11:00 26 Dec 2008

Bought my daughter a WDC 320gb external hard drive for her XP lap top. Was meant to be virtualy plug and play operation but had terrific problems getting it to appear as a device under my computer. Tried to use it on my p.c. but again it won't show. Eventualy I got it onto her laptop but right clicking or left clicking on the device produced no result. I have tried to download software from WDC web site but can't. Any suggestions where i've gone wrong .

  woodchip 11:12 26 Dec 2008

Did Windows Recognize it? If it did you should see a icon with a green arrow near clock. If its there then its loaded as a removable drive. Press Windows key plus E key to open Windows Explorer the drive should be near to the bottom on the left. you can drag and drop files to it etc

  LAP 11:17 26 Dec 2008

I have a WDC external h/drive. Just got another for my wifes computer. Both just connected up,,plug and play. I have connected both of ours via USB. Yours may be faulty.

Someone may be able to help.

  Ranger 11:24 26 Dec 2008

Woodchip. I have tried to drag and drop a few items without success, it doesn't seem to work. Connection is via USB 2. The problem initially was to get it recognised but now it's just sitting there.

  RobCharles1981 11:27 26 Dec 2008

I'm thinking you may need to format it in Diskmanager does it show there???

  woodchip 11:28 26 Dec 2008

Can you see it in Explorer? If you can, the drive may not be setup. Right Click My Computer\Manage\Disc Management look for the drive it may show as unallocated Space right click the drive setup a primary Partition on the drive the format it

  LAP 11:35 26 Dec 2008

On this site click here

It appears that the USB "drive current" requirement for this unit exceeds the capabilities of most available USB 2.0 drives. Western Digital's lower capacity units such as the 120 GB unit works fine. When WD Support was asked what drive current is required by the 320 GB unit, they stated that anywhere from 600 to 1000 milliamperes is needed. Where standard specifications of USB drivers are examined, they state a maximum specification of 500 milliamperes per port. This explains why 4 of 5 computers I tried failed to work with this drive. WD offers for $10 plus shipping a USB Booster which essentially parallels 2 USB ports for double the available drive current. I am angry that nowhere is this problem ever mentioned when adverising this product.

  crosstrainer 11:48 26 Dec 2008

Open Control Panel.

Double click the Adninistrative tools icon.

click on the tree view that displays storage.

If your new usb device appears, format it from there (NTFS)

If not, then you can eber your BIOS screen (from boot up) and enable usb legacy support,

If that fails, I would return for exchange / refund

  Ranger 11:58 26 Dec 2008

Thanks guys will have a go when i get back later to day. Lap, my drive is not the portable 2.5 but connection is via the USB 2 and a power cable, sorry if i misled you there. I shouldn't need to format this drive and i'm looking towards a refund / exchange possibly

  Ranger 15:46 26 Dec 2008

Hi guys. The drive is there listed as local drive F. I have tried to send stuff to it and drag and drop. Both are met with an error message saying there is an I/O device error. I have checked and rechecked the device drivers and am advised that I have the most up to date drivers. I'm going to return it in the morning to the shop i bought it from. Thanks to all

  Ranger 16:08 26 Dec 2008

Hi guys . All very technical and certainly not for a novice. I decided to have once last go before returning it. The drive needed formatting and is now working. Daughter happy, Dad is off to the pub. My thanks to you all and best wishs for the New Year.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique