Problem updating Samsung Smart TV software

  keesh 09:30 02 Mar 2015

Hi, i am trying to update my Samsung smart TV SW, but so far all methods have failed. Model number UA55D6000. Current version installed on TV = "T-GAS6DEUC-1001.3". Latest version downloaded from Samsung website = "T-GAS6DEUC_1024.0". I have downloaded the .exe, copied it to USB, ran the .exe (which then extracted and put the files onto the USB key), plugged in the USB key into the TV, the TV finds the USB key and shows the files, but when i select "upgrade sw via usb" it says "upgrade files not found". i have tried diff USB keys, and different USB ports on the TV. Any ideas please? Thanks.

  robin_x 10:52 02 Mar 2015

Well, with the caveat that you should only upgrade to fix bugs that you have noticed, or gain features that you definitely want...

(Firmware updates carry a degree of risk) Support pages don't recognise UA55D6000 or some variants that I spotted while searching.

eg UA55D6000S UA55D6000SKXXY or whatever.

What is your full model number and did you download from the Samsung site or 3rd party site?

However, I did grab a copy for a 6100 and ran it in a folder on my desktop.

The instructions say you did everything right, but the software or instructions may be wrong.

It makes folder structure T-GAS6DEUC > image > files.

Try selecting all the files and copying into T-GAS6DEUC folder and into USB top level.

So you will have 3 copies in total. See if the TV spots what it wants then.


By searching on T-GAS6DEUC, I also found 1 page from someone trying to hack his TV (Root it).

Someone else says UA models should have T-GAS6DAAC

But on genuine Samsung UA6100 download your DEUC seems correct.

I didn't search any further.

click here


Another (remote?) possibility, might be USB flash is the wrong format and, although TV can see files, it's causing a problem.

Reformat USB drive to FAT32 and NTFS or try the TV's Format capability on it if it allows.

  robin_x 10:54 02 Mar 2015

Also download the firmware again, in case you got a dodgy transfer.

  BRYNIT 11:02 02 Mar 2015

If your TV was made 2014+ Have you tried updating the firmware via the network CLICK HERE for instructions.

If you put the firmware into a folder on the flash drive this may prevent the TV finding it.

  robin_x 11:32 02 Mar 2015

I was closing my tabs, and got sucked in again...

I downloaded T-GAS6DEUC for a UE55D6100 not a UA as I thought.

Double checking, I found it is easy to list all firmware for 55" TVs. Samsung site doesn't object to that search (Filter by Support > Firmware on link below)

UA6000D series is not listed.

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Meilleurs drones (2018)