Problem sharing a Printer on a home networ 2 PC's

  freaky 21:25 09 Jun 2005

Set up a home Network on 2 PC's both using XP via ethernet cards. Main purpose was for both PC's to share one Broadband connection and also one printer.

When I set up the Network I enabled printer sharing, the Broadband connection works OK. Just been trying to share the Printer, on the host computer I named the printer for sharing as 'my printer'. Then went to the slave computer >Printers and Faxes > Add a printer > browse for printer on another computer/network. The box that appeared showed in highlighted blue 'Microsoft Network'. In the box titled 'Printer Name' I entered 'my printer' then Next. But all I got in response was an error message. I have tried all other alternative permutations on the Wizard with no success. I would point out that both computers were switched on plus the printer. Would be grateful if anybody could tell me what I am doing wrong.

  RealDopey 22:39 09 Jun 2005

You have comp1 with the printer on it and comp2 that wants to use the printer connected to comp1

Set up printer in normal way for comp1, then click start, click printers and faxes highlight the newly instaklled printer, Right Click and then click on Sharing. Share the printer.

Now go to comp2, click start, click printers and faxes, click the "Add New Printer" Icon.

Make sure select "network" printer and not "Local" when you follow the instructions through you should be able to click on your workgroup name and see both comp1 & comp2 open up comp1 and you should be able to select the printer attached to comp1, just follow the rest of the wizard.

  freaky 09:16 10 Jun 2005

Yes I understand all that thanks, but unfortunately it does not work, the printer attached to comp 1 is not recognised by the Wizard on Comp 2. If I Browse on comp 2, then in the list of printers available all it comes up with is 'Microsoft Windows Network' no sign of the printer attached to comp 1.

  Aspman 15:14 10 Jun 2005

Can you see the other computers from each other?

  freaky 15:39 10 Jun 2005

Not quite sure what you mean exactly, but as I said above, the only positive reaction I get is when I ask the Wizard to Browse for a printer, it shows in the box that should contain a list of printer's the words "Microsoft Windows Network" which is highlighted in blue !

One question, when I right click on the particular printer on the host PC it shows that it can be shared and asks for a name for the printer. Can this be any name, or must I put the actual name of the printer i.e. HP Photosmart 7900 series? Also is the name case senstive, and can you include spaces?

Many thanks, freaky.

  flavas 15:53 10 Jun 2005

did you run the 'set up network wizard'?
If so what is the name of the workgroup that you specified?
After setting up the home network, when you go to add a printer, you should see the workgroup name, on the network browser, and double click on the workgroup name and you will see 'myprinter'

  freaky 16:17 10 Jun 2005

hi, yes I did use the 'set up network wizard'originally with the workgroup name as MSHOME.

Also the following: -

Host Computer Description: OLD.....Computer Name: Philip. Workgroup Name as above.

Slave Computer Description: MESH.....Computer Name: Ayesha. Workgroup as above.

When I go to the slave computer to add a printer, there is no mention of a workgroup name, and no mention of a network browser!

  flavas 16:26 10 Jun 2005

then double click on windows network and mshome will appear underneath the windows network when earching for the printer.

  freaky 16:35 10 Jun 2005

Thanks for that, I will try that out early this evening as I have to go out now. Will post the outcome as soon as I can.

  freaky 20:50 10 Jun 2005

Back now and tried your suggestion on double clicking the highlighted "Microsoft Windows Network" shown in the list of printers. The hourglass appeared for a few seconds but nothing happened.

Then tried selecting 'connect to a printer on the internet or on a home or office network'. A box appears labelled URL and gives an example of what to enter:-

click here

I entered what I thought was correct, but got an error message after clicking next. Obviously I did it wrongly, and this is where the problem lies (hopefully). Any suggestions please.

  freaky 20:55 10 Jun 2005

Where my last post gave Click here' was because I typed the example URL shown by the Wizard.

I will give the URL example again, but try to alter it slightly so that it does not show as a link by leaving the http: from the beginning: -


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

How Pentagram and other design agencies aim to double the number of creative female leaders

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?