Problem seeing USB HDD

  FnG 14:12 11 Sep 2008

I have just bought a second hand Sony 60GB USB external HDD. My PC already has 2 internal HDDs fitted. I attached the HDD and used HDDwipe by HDDguru to wipe the disc before starting to use it. I know I need to format it next, but My PC won't now recognise the drive. It's present in device manager and states that it's working correctly but it doesn't show in 'My computer'. Thanks in advance for suggestions.

  woodchip 14:29 11 Sep 2008

Go into Manager and click on Format for the drive. then see if it shows

  FnG 14:39 11 Sep 2008

In device manager, the drive shows, states it's working correctly, but there's no option to format.

  woodchip 14:44 11 Sep 2008

did you click on the drive letter first

  FnG 14:49 11 Sep 2008

I can't see any drive letters? Am I checking in the right place?

  woodchip 16:25 11 Sep 2008

Right Click My Computer\Manage\Disc Manager then if you see the drive right click it and choose format. Other than that Go into BIOS and make sure USB Legacy is enabled

  FnG 17:05 11 Sep 2008

In control panel/system/hardware/device manager it shows the USB drive as present without any problems (device working correctly). When done the way you've explained above, it only shows my internal C and D drives, not the USB HDD. I'll check my BIOS settings but I think they're ok as the device is being recognised in device manager. It must surely be something to do with deleting the NTFS file system when I used HDDwipe. Help!

  FnG 17:16 11 Sep 2008

The USB settings are enabled. If all else fails, would it be possible to disable my C and D drives, then use the USB HDD as main, then run a set up from disc. Once it's formatted I could cancel the setup, remove the drive, re-enable C and D, then connect the USB HDD. If it's been formatted, it should be 'found'. Would this work?

  EARLR 19:11 11 Sep 2008

There are a lot of easy to use solutions.

Good Luck

  Shuffty 19:21 11 Sep 2008

If you wiped the drive it must be formatted before windows will see it ,go into disc managment and format ntfs

  karmgord 19:54 11 Sep 2008

try settings,control panel,administrive tools,computer management,disc management,if drive shown click on drive then partion,& format it

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

How Sketch and InVision have revolutionised our design workflow

The best tech gifts for Christmas 2017

Les meilleurs jeux de société (2017)