Problem with new flash dive.

  cocteau48 19:59 07 Nov 2008
Locked

I have just bought a new Sandisk Cruzer 8GB flash drive. I plugged it into my Vista laptop which recognized it as new hardware and it appeared as it should in Explorer.
I then removed it from the machine using the safe to remove option.(right click context menu)
Upon reinstalling it into the laptop it does not now appear in Explorer - nor does it does show up as a portable device in Device Manager but it does appear in Administrative Tools/Computer Management/Storage/Disk Management.
If I reboot with the flash drive installed it does then appear in Explorer.
(I also have a 1 Gig Kingston drive which works perfectly.)

Any ideas as to what is happening here?

  Pineman100 20:17 07 Nov 2008

I've sometimes found (in XP) that if I "safely remove" a USB device, and then put it back in again, the computer won't see it. But if I restart, then all is OK again.

Can't explain it, I'm afraid.

  cocteau48 20:28 07 Nov 2008

Pineman100
I will only recognize it if it is rebooted with the flash drive pre-installed.
I have noted that in Computer Management when the drive is recognized after a reboot as above it is allocated a drive letter but when I just insert the drive although it shows up in Computer Management it has no drive letter allocated - nor will it let me allocate one.

  Technotiger 20:29 07 Nov 2008

I never use the 'safe to remove' option with USB flashdrives - as they are hot swappable, I just ensure that that they are not being read or written to of course.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?