Problem with my Acer Aspire laptop

  erikjanuari 17:56 05 Feb 2018

Hey everyone,

Before I state my problem, I am not a computer guy. So please, if you use any computer terms please explain them to me :) Anyway, this is what I know about my laptop. It has a 64 bit system, and runs windows 7 It's an Acer Aspire 5750 and I bought it new in 2011 (or 2012 don't remember exactly)

This is the problem : After I press the power button, it boots up but gets stuck at this screen (see image) It won't respond to pressing F2, and when I press any random key on the keyboard it starts making a beep noice for every key I pressed. I have tried booting it up while unplugging my mouse and battery but both didn't work. I had this problem happened 2 times already, and what I then did was wait 1 day and then try again and it would start up again immediately.

click here,

Dude

href

Thanks

  erikjanuari 17:57 05 Feb 2018

This is the 2nd picture :

click here

href

  erikjanuari 17:59 05 Feb 2018

Ok it won't let me post the link (forum thinks it spam, wtf) of the 2nd picture (the screen my laptop get stuck on)

Basically, all I see is the word "Acer" in white letters with a black background, and on the bottom left it says 'Press F2 for setup"

  Fruit Bat /\0/\ 18:23 05 Feb 2018

If its stuck on the Acer logo screen then it's not completing POST (power on self test).

try removing and refitting both the memory and the hard drive if they are easy to get at.

  erikjanuari 19:09 05 Feb 2018

Thanks for your reply,

Unfortunately did this not work, it is still stuck at the same screen. I removed the hard drive and the ram and then plugged them back in again

  Fruit Bat /\0/\ 19:18 05 Feb 2018

Disconnect mains lead and power lead

press and hold power button for 30 seconds

reconnect mains and retry.

  erikjanuari 19:26 05 Feb 2018

Thanks again for your reply. Unfortunately this didnt work either. I removed the power plug cord and battery, then held power button for 30 seconds and then plugged the battery and power cord back in.tried starting it up and didnt work

  Fruit Bat /\0/\ 20:44 05 Feb 2018

make sure no USBs attached or DVD disks in drive

try booting with RAM removed, it should beep at you. iif it does reft RAm an retry the boot.

  erikjanuari 20:55 05 Feb 2018

Omg, it just booted up. However I dont think its because of the ram thing (as it didnt beep) PLEASE let me know what I should do now to prevent this from happening again.

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Test : les écouteurs Bluetooth Honor xSport AM61