Hot Topics

Problem with the driver for Local Area Connection

  MCMSBre 11:46 13 Mar 2016
Locked

Hello,

So yesterday i woke up and turned my PC on to find out that i have a big red "X" on my connection thingy in the bottom right corner. When i tried to use the "Solve Problems" option i got this message: "There might be a problem with the driver for the Local Area Connection Adapter". I searched online on my phone to find some solutions. I found a couple:

-Update network adapter drivers

-Deinstall all those drivers and let windows install them again

-Tried connecting wirelessly, but once again i got the same problem (just this time it said "wireless something something 11 adapter)

-Tried using my ethernet cable on my laptop, it worked, it´s not in the cable

-Disabled and enabled Local Area Connection in the "Change Adapter Settings"

-Made sure TCP/IPv4 and TCP/IPv6 are both on Auto

Nothing worked. In the end i decided to restore my PC to a couple of days ago. In those couple of days there were some Windows updates that got installed.

After restoring, my internet worked again. I decided to immediatly update my Network Adapter Drivers. Upon doing that my internet icon went crazy, one seccond i had internet the other not. Now that i think about it it was probably because those drivers were being installed. After that i restarted my PC a couple of times. On one restart those updates got installed (18 of them), but after every restart my internet worked. I am not sure if the problem is in those updates since the first time i got them installed it was about a week before my problem occured.

After all of that i posted my first cry for help online. I got one answer and the person told me to download and run "Tweaking Windows Repair". I downloaded it but i didn´t run it until today. The reason being, my internet worked, and a part of me thought (hoped) that the problem was gone... Oh silly me.

Today i turned on my PC with fear, unfortunately my fear was justified. Same thing. First thing i tried was restoring my PC again, so that i can at least have internet access and start working on the solution. The problem is, this time it didn´t let me go that far back, it only gave me the option to go back to yesterday. I did that, but this time it did not work.

Then i decided to use the "Tweaking" program. It finished, problem was still there. I did it again, since it said that they recommend doing it twice. Still nothing. After that i decided to manually deinstall all updates that windows installed for this month. I managed to deinstall everything (even microsoft .net framework, which i don´t know if it´s good or bad). The only thing i was not able to deinstall was "Adobe Acrobat Reader DC (15.010.20060)", but only because it didn´t let me do that.

I honestly have no idea what to do next, and i hope some of you have the solution.

My IPCONFIG /ALL:

Windows IP Configuration

host name..............................: user-pc

primary dns suffix....................: (blank)

node type...............................: hybrid

ip routing enabled....................: no

wins proxy enabled..................: no

Tunnel adapter Teredo Tunneling Pseudo-Interface:

media state.............................: media disconnected

connection-specific dns suffix.....: (blank)

description...............................: teredo tunneling pseudo-interface

physical address.......................: 00-00-00-00-00-00-00-E0

dhcp enabled............................: no

autoconfiguration enabled..........: yes

I have no idea what any of this is, but i saw some people do it so i did it as well. The only thing i think i know is that DHCP should be enabled, and i did that, i´ve put TCP/IPv4 and TCP/IPv6 on auto. Unless there is another way to enable DHCP.

So there it is, I hope some of you know what the problem is, and hopefully it can be fixed. If more information is needed i am more than happy to provide it.

System spec:

Windows 7 Ultimate

Processor: Intel(R) Core(TM) i3-3240 CPU @ 3.40GHz 3.40 GHz

RAM: 8,00 GB (7,89 GB Usable)

64-bit OS

Thank you.

  difarn 17:28 13 Mar 2016

Have you tried disabling IPv6?

Have you tried renewing the TCP/IP stack that sometimes resolves connection problems? There is a Microsoft Fix-it that can do this.

click here you prefer to do it yourself via Command Prompt these are the instructions

click here

If

  MCMSBre 19:55 13 Mar 2016

Thank you for your answer,

I´ve disabled IPv6 but it did not help.

I renewed the TCP/IP using the command prompt. The strange thing is that the picture from the link you provided had a lot of lines when executing the command, for me I only got: "Resetting. OK. Restart the computer to complete this action."

  difarn 08:23 14 Mar 2016

Did it work?

  MCMSBre 12:30 14 Mar 2016

No, nothing helped. The problem is still there.

  difarn 12:58 14 Mar 2016

When you clicked on "obtain an IP address automatically" did you also click on "obtain DNS server address automatically"?

Item 6 in this link guides you how to do this.

click here

  MCMSBre 15:36 14 Mar 2016

Yes, i have done that at the same time i set IP address to auto. Actually i haven´t set anything, everything was already on auto, so i just left it as it was...

  difarn 16:43 14 Mar 2016

Have you tried to reset the Network Adapter with a Winsock reset?

click here

  Svol 16:59 14 Mar 2016

To clarify:-

When you tried to restore to an earlier time, did you tick the box 'Show more restore points', as in:-

  • Goto 'Windows Start>Control Panel>System and Security>Action Center>Recovery>Open System Restore'
  • Click 'Next'
  • Click 'Show more restore points'

Also, have you tried the following which will uninstall the Network Adapter driver via Windows Device manager and then perform a reinstall:-

  • Goto 'Windows Start' and Right-Click 'Computer'
  • Select 'Manage>Device Manager'
  • Expand 'Network Adapters' to display list.
  • Right-Click your Network Adapter and select 'Uninstall'
  • Right-Click your Computer name shown at top of Device Manger Window and select 'Scan for Hardware changes'.
  • Windows will search for and install the Network adapter driver if can find the correct one.

If you repeat the 'IPCONFIG /ALL' check, it should show the active Network adapter driver in the output list, if it has loaded successfully. For example, 'Wireless Lan Adapter' or 'Ethernet Adapter Local Area Network' etc.

  MCMSBre 18:03 14 Mar 2016

Thank you both for your asnwers.

I have done all of those suggestions, some now some before. It did not help.

I have tried to do the restore with 'Show more restore points' but i´ve only had a couple of more with that option, all not too long ago, just a couple of days, at least not before those updates got installed.

I have done the IPConfig /All again, but i got the same results as before.

  difarn 18:53 14 Mar 2016

Did you run the network troubleshooter?

click here

This thread is now locked and can not be replied to.

1x1 pixel
Elsewhere on IDG sites

Microsoft to release Surface Duo on 10 September, starting at US$1,399

Landscape Illustration tips from leading illustrators

How Apple Camp at Home can entertain your kids this summer

iPhone 12 (2020) : date de sortie, prix et autres rumeurs