Problem with cursor navigation on sites such as PCA

  mooly 07:53 27 Aug 2011

Using Vista and IE9.

For some weeks when typing text such as this, if I want to move the cursor (for example to go back a few characters to correct a typo) I always used the arrow keys on the keyboard and the cursor moved as expected.

On sites such as PCA this doesn't work for some reason. If I tap the "back arrow" key say 5 times the insertion point does indeed move back but there is no visible indication of where it actually is. The actual cursor remains at the end of the text just typed. The only sure way to move the cursor to a known point is with the mouse and a left click but even then the actual visible cursor remains at the end of the text.

PCA isn't the only site that does this, there are one or two others that I use that do similar. I have tried using compatability view and that made no difference and have also tried this on a new Vista instal and that was the same.

Just me or has any one else had this happen ?

  Crosstrainer2 07:56 27 Aug 2011

Works fine on my iPad......and also ok on my iMac. I'm guessing you have already played withe the mouse settings, so looks like a Windows issue.

  mooly 18:14 27 Aug 2011

I guess so... if I find anything out I'll update this thread of course.

  woodchip 18:45 27 Aug 2011

sounds like its you computer that's at fault, or a windows problem as i use xp home on all my pc's and they all work like you want yours to

  mooly 07:29 28 Aug 2011

This is odd... I haven't done anything besides post this thread... but it is now (at this moment anyway) working as it should. Arrow keys move cursor in all directions.

And I have just opened another site on another tab to check, and that still misbehaves in the same way.

Too much of a coincidence methinks :)

Whether PCA will stay this way though...

  mooly 12:05 28 Aug 2011

This gets stranger. Thought I would just try it again and it failed, same as before but investigating a bit more I find the following.

  1. If I click the empty "reply to this topic" message box first I get a steady unblinking cursor. Move the mouse pointer out of the message box and this "text insertion point cursor" dissapears. Move the mouse point back into the box and it reappears. Original complaint of no navigation by arrow keys is present if I type.

  2. If I left click the empty left hand margin before clicking in the message box it seems to work correctly every time. I get a blinking cursor in the message box that both remains and is navigable no matter where the mouse is.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)