mr blue vein 19:00 07 Dec 2008

Can anyone please advise...
I have a PC & 3 laptops that are connected to the internet via a Sky Router, one of the laptops & the desktop PC is connected via a Belkin USB adaptors, the other two lap tops have built in wireless. Everything has been working fine for monthes until a few days ago, for some reason the Desktop using the USB adaptor won't let me go on the internet, it says it has "limited or no connectivity". I have re-installed the drivers, tried the other USB adaptor from the laptop, tried to connect using Windows rather than the Belkin set up but nothing seems to work. I also went on line to Belkins website to see if there were any driver updates etc.. I have no problem with any of the other machines & I can connect the PC if I hardwire it straight into the router. The message I get when I click onto the "you have limited or no etc" basically says "This problem occured because the network did not asign a network address to the computor" when I tried the "repair" function I got the message "Windows could not finish repairing the problem because the following action cannot be completed - renewing your IP address"
I can't get my head round this as all I did oridinally was run the Belkin CD, plug in the adaptor & connect once I had put my SKY key in...
I'm not very IT minded hence I choose the Absolute beginners section.

Any help would be apreceiated

  T0SH 21:22 07 Dec 2008

Sky Routers can be a bit of a nightmare

If you have not already done so power down your router for a few seconds then power it up again

this action often fixes connection problems

The next problem I see is that you are using the Belkin utility to handle your wireless connection often it is way better to use the wireless zero option built into windows

To do this uninstall the belkin utility from add remove programs then unplug the belkin adaptor

Reboot the PC once it is fully up to a desktop insert the Belkin CD into the drive but hold down the left shift key to stop it auto running next browse the CD you will see a folder called drivers which contains a sub folder open this shows two more folders you want the one called Win2KXP open it and select the detail view option from the View pull down menu in the toolbar at the top this will show three files the one you want is rt73.inf if you right click on this you will get a option to select Install select this

It will not do anything this action just tells windows how to install the driver for the Belkin

Do not remove the CD from the drive ,now pluging in the belkin to a USB port will start up the windows installer if prompted choose the automatic install

Once it is successfully installed right click on the small monitor Icon down by the clock and choose View Available Networks select yours from the list should bring up a box for you to type in your security code

Then it should connect

Cheers HC

  mr blue vein 20:19 08 Dec 2008

Hi Tosh

Ok I have just gone through your instructions & no joy. What happens is it trys to connect & I get "Aquiring network address" then eventually it goes over to "Limited or no connectivity" as I have described before. Perhaps I did not make myself clear the first time but I have already tried your idea, anyway it was worth another bash..

Do you have any other ideas as I'm at a loss ?

  T0SH 21:54 08 Dec 2008

Try this but first create a restore point just as an insurance policy, download the winsock fix from here direct download

click here

save it to a known location then run it and reboot your PC then with your fingers and toes crossed try to connect again

Cheers HC

  mr blue vein 22:07 08 Dec 2008

How do I create a restore point ?

I am a complete novice

When you say keep your fingers & toes crossed it concerns me, what do you think the problem is ?

  mr blue vein 22:00 09 Dec 2008


Can you advise or can anyone else help?

  brundle 22:11 09 Dec 2008

"I can connect the PC if I hardwire it straight into the router." means it's not a Winsock problem, or a TCP/IP problem. Can you try the original adapter with another router? Does the adapter detect other wireless routers within range? What happens if you try the desktop and original adapter when all the other machines are switched off? T0SH's suggestion (and what you seem to have tried) regarding sticking with the built-in wireless management is a good one, one less thing to troubleshoot.

  mr blue vein 23:47 11 Dec 2008


Thanks for your suggestions.

I don't have another router & no I cannot detect any other wireless routers from the PC or any of the laptops I'm currently using. I have tried the PC when all other machines are turned off & no difference. As previously explained I did try the other Belkin adaptor that I currently use on one of the laptops & this still would not work on the Desktop.

I'm not an expert but it seems it's problem with the PC rather than the Belkin adaptor or the Sky Sagem router..

What do you think ?

  T0SH 14:26 13 Dec 2008

after re-reading this thread and assuming you are using windows XP where you said is was working normally in the recent past ?

try this Click on the "Start" then from the menu options select "Help and Support" on the page that opens type System Restore into the search box top left and click the green arrow

this will bring up a list of search results, the one you want is listed under the heading
"Pick a Task" entitled

"Run the System Restore Wizard"

clicking on it will bring up with the "Welcome to System Restore" window preselected to

"Restore my Computer to an Earlier Time"

clicking the "Next" button will bring up a calendar with some dates in Bold type these are the selectable ones you can also use the < symbol to the left of the current month December to select the previous month November with its bold selectable date options

Select a date when your PC was connecting wirelessly and before this problem occurred and click next to start the restore process

Your PC will reboot during this process and will confirm a successful restore on boot up into windows

There is no need to worry about losing anything apart from you will need to redo/reinstall any windows updates and any new software you have install since the date you select to restore back to, also if it does not fix the problem then is is fully reversible by running the System Restore Wizard again and choosing

Undo my last Restoration

from the available options

Cheers HC

  Jingis 19:53 13 Dec 2008

I have just today had the same sort of problem, and not for the first time.

There is software in Windows to manage wireless connections.

There is also the software which comes with the wireless adapter.

I would suggest that it is when both the above are enabled that this problem arises, and that you need to disable one of them.

PS: If Windows is to manage it then the "Wireless Zero Configuration" service needs to be set to automatic

  brundle 14:18 14 Dec 2008

"I'm not an expert but it seems it's problem with the PC rather than the Belkin adaptor or the Sky Sagem router.."

It does seem to be the logical conclusion - if you only install the drivers for the adapter the above post won't be relevant but is a good point.

Uninstall the whole lot, run CCleaner to clear out temporary files and clean the registry (save a backup when prompted), reboot, try again.

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique