problem connecting Epson SX535WD scanner

  morters 16:56 21 Sep 2012
Locked
Answered

A couple of weeks ago my TP-Link wireless router packed up. Through the support team, I eventually realised it needed replacing. This took ten days, during which time I had no wireless connectivity, preventing internet access and use of an Epson SX535WD printer.

When I eventually got a new router and access to the internet, I found I could not connect my printer. Epson support helped me get it connected so I can now print and copy. But it will not connect to the scanner – I get ‘Cannot communicate with the scanner’ error message. Epson support took me through various tests/adjustments but, though everything suggested that the scanner should be working, it wasn’t. Epson think it may be a problem on my pc (Dell, Windows 7) but I am at a loss as to what. Have tried disabling firewall and anti-virus but to no avail.

I’m not at all technically minded and am quietly going round the twist wondering what the hell to do. Can anyone advise, please?

  morters 17:34 21 Sep 2012

Thanks, Woolwell

Not sure what you mean by 'scan from printer to pc' - is that any different from just scanning something?

Yes, have uninstalled/reinstalled all software (this was initial solution Epson suggested, ie reinstall printer again fro scratch). When I found the scanner problem, they suggested uninstalling/reinstalling just the canner software element. And, yes, added new IP address

  morters 17:36 21 Sep 2012

Sorry, 'canner' should, of course, read scanner!

  morters 18:20 21 Sep 2012

Thanks Woolwell

Managed to scan via printer (result!) but saw no indication of printer on pc. I might be doing something stupid, like I said, 'I’m not at all technically minded'.

  woodchip 18:29 21 Sep 2012

After Uninstall a Printer you need to remove as much as you can find on the system, both in Regedit and Windows Find. Then reinstall software as though you may think you removed the Printer there are lots of bits left on the PC including some settings, this may be what is stopping it working

  morters 18:46 21 Sep 2012

Thanks woodchip

I'm afraid you've lost me somewhat. You say 'both in Regedit and Windows Find' - I simply went to 'uninstall a program' to delete, have no idea what Regedit is, sorry for my ignorance.

  morters 19:28 21 Sep 2012

My apologies Woolwell and woodchip, but I have to go out for pre-arranged meeting at 20.00. Thank you for your help and apologies for being a pain in the nether regions. Won't be able to post again until tomorrow, but please, if you have any suggestions, post here.

  morters 09:31 22 Sep 2012

Sincere apologies for enforced break.

If anyone's still out there, in my anxiety to try and sort out the scanning element, I forgot about something else that turns out to reveal another problem:

When using the Epson wizard to install the printer, I was instructed to temporarily connect the printer to the pc with a USB cable and not to remove it until told to do so. Near the end of the process I got an installation failed message, though printing and copying was possible. Because installation did not complete, I did not reach the stage where the wizard instructs you to remove the USB cable; removing it now stops the printer working. So now I have non-wireless printer!!!

This really is a bit of a mess. Would it be pointless rebooting in safe mode with connectivity and attempting to follow the wizard again? Sorry if that flaunts my ignorance.

  morters 10:20 22 Sep 2012

Thanks, Woolwell, and again apologies for long break.

The USB connection was the recommended method by Epson, and, being a good boy, I always do as I'm told! But you are right, the choice comes fairly early in the process, so I'll try the alternative; presumably I should uninstall all software again??

Yes, the WiFi light is lit.

  morters 11:23 22 Sep 2012

Will delete everything then. I'll therefore be some time before I can respond as to success or otherwise, thanks. And agree, when it's working the printer is superb.

  morters 16:35 22 Sep 2012

Well, that was a bit of a nightmare, but eventually mananged to get everything working, thank you so much for your help, Woolwell. There are 3 methods of installation suggested by Epsom, the first of which is the one that initially failed and prompted me to post problem here. The second, and one that seemed most likely (to me!) to succeed, failed - I got bogged down with all sorts of passwords and other things. Sorry I'm being vague but didn't keep record of options; while I might be able to retrace installation and describe 3 installation options, I'm not prepared to possibly bugger up what I've achieved! Third method, which looked least likely to succeed, actually worked! Yippee!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Thank you again but I have to wonder why Epsom support couldn't suggest this option in the first place.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Mi Mix 3 UK Review: Xiaomi's Flagship Slides Into The UK

Freelance Wars' has given us a year of hilarious, oh-too-true GIFs about nightmare clients and…

Apple Maps vs Google Maps

Amazon Prime : Prix et avantages