Problem changing from Wireless to Ethernet

  User-9A919F67-6ADE-4BFB-8B35A0F56CB2F7D6 11:10 13 May 2004

I have two PC's which are connected into a Belkin combined Modem/Router. One is connected via a cable and the other via a wireless adapter. Everything works great, except that one PC is working at 100Mbps and the other at 10Mbps.

I purchased a 100 Mbps Ethernet PCI card and a straight-thorugh cable. I have installed this into the PCI slot (in the PC with the wireless adapter) and plugged the cable into the back of this and into a spare port on the router. When I boot the PC up the 100 light comes on on the back of the card and an orange light flashes. On the router an orange light shows up for the port where the new cable is plugged in.

When I log on to my Admin account on XP I see two network connections. One is fine (the wireless connection), but the other (new Ethernet) has a red cross. If I click on this I get a window, and in here it says that the network cable is unplugged.

If I log on to the router it shows that I have two connections with this PC and if I look at the MAC addresses I can see two different ones.

How do I get rid of the "network cable unplugged" message?

I have also tried unplugging the wireless USB adapter and rebooting the system. This makes no difference. From the lights on the back of the ethernet card and the front of the router, plus the fact that the router appears to be able to get details from it, I can't see where the problem is.

  georgemac 11:28 13 May 2004

have you tried uninstalling the software for the usb wireless adaptor and removing the usb wireless adpator in control panel?

If you do this and run the network setup wizard again or the router software/wizard this may work.

Do not have a lot of networking experience so not sure, but it looks like the setup is confused by having 2 connections to 1 pc.

No, I haven't tried uninstalling the USB software yet. I was trying to get the existing connection going so that I can access the net at all times.

As long as both networks have a different MAC address I wouldn't have thought there would be a problem. This is the case on Unix servers anyway, so I guess PC's could be different.

I'll give this a go tonight.

I have a fair bit of networking experience but am by no means an expert.

Sorry, I meant I was trying to get the new network up and working before disconnecting the old one.

Tried loads of things last night, none of which have helped.

I took home an identical network card from work and tried that in my PC instead. I also took home another cable and a cross-over cable. I swapped the card(s) to an alternate PCI slot, which I know works okay. I removed my wireless USB adapter and uninstalled the Belkin software. I downloaded the XP 3Com 3c905tx drivers from the internet and reinstalled the card using those. Nothing. All it says is "network cable unplugged"

In Device Manager, before I started yesterday, the card was shwon as "3Com 3c905TX based Ethernet Adapter". After I download the Windows XP drivers it says "3Com Etherlink 10/100 PCI NIC (3c905-tx)" which sounds right to me.

In Device manager I also have a network adapter labelled "1394 Net Adapter" which has always been there but I dont know what it is. I have tried disabling this but that doesnt help. I have checked the resources etc and everything looks okay. No conflicts etc.

Each time I enable the 3com card, in Event Viewer (System) I get two messages. The first is "Information - Source Tcpip - Event 4202" which says "The system detected that network adapter \DEVICE\TCPIP_{54CAA590-6652-431D-8C2B-C5E6FD261546} was disconnected from the network and the adapters network configuration has been released". The second is "Warning - Source Server - Event 2504" which says "The server could not bind to the transport \Device\NETBT_Tcpip_{54CAA590-6652-431D-8C2B-C5E6FD261546}"

If I get a DOS prompt I can ping with no problem. On my Belkin router the new network card gets its MAC address picked up okay and is assigned an IP address.

Any ideas?

I'm starting to lose patience with this now.

I have tried every suggestion under the sun and nothing seems to work. I know the card works okay, and I know the cable is okay. Both have been tested at work on XP systems and worked perfectly.

Could this be something to do with the IRQ that has been assigned? If this is a possibility how do I change it? In Device Manager I can see what IRQ has been assigned but the option to change it is greyed out. (The IRQ is 11 by the way).

I sent an email off to Belkin last week to ask for their help but as usual I have heard nothing back (there's a surprise).

Any ideas?

  AndySD 12:40 18 May 2004

Try setting a new hardware profile and just set the ethernet adapter on it leaving the wirless adapter on the first hardware profile.

I'll give that a go tonight.

If that doesn't work then the only thing I can think of is to try a different make / model of Ethernet card. Maybe there is a problem trying to connect a 3Com 3C905Tx card to a Belkin modem/router.

If that doesn't work I'll give up.

I hate being beaten by computers !!!

Last night I disabled the non-working Ethernet card then switched the PC and the modem/router off.

This morning I powered both back on and checked the DHCP list in the router. The only entry it had for this PC was for the wireless network. I then enabled the Ethernet card (and got the usual cable unplugged message) and rechecked the router. This time it had an entry and an IP address for the Ethernet card. Why is it that the router can see the Ethernet card but not the other way round?

  Gemma 09:20 19 May 2004

Just a comment. The 1394 Net Adapter is your FireWire port. Presuming you are on XP, check the network configuration to see if this is bridged to the ethernet. If it is then you must un-bridge it as XP has a fault in this area which causes all sorts of problems.

  computernerdiamnot 09:24 19 May 2004

Have downloaded the newest firmwear update from belkin. I know a lot of people who purchased a belkin router had problems and had to dowload this.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?