Problem with Belkin Pre-N router & DSL 300-T modem

  yewy 18:16 01 Feb 2006

Can anyone here please be of assistance?

I am installing a belkin pre-n router, i go through the set up but it wont connect to the internet.
I am using a d-link dsl300t as the modem and my isp is Tiscali, i have even followed advice on the link above but nothing has worked. Belkin tech support has been quite helpful and i have attempted to change the ip address on the modem and turn off dhcp servers on the modem.
When i ping the modem through the router i get no connection, but the router pings just fine. I can even connect my lap top to the router wirelessly but just cannot access the internet.
Belkin tell me the router is fine and it is modem problem. Tiscali and D-Link both assure me that as i can connect without problem without the router then it is this that is at fault.

Can anyone help please? This is driving me nuts!!!!!!!!!!!!!!!!!!!!!
Thanks - yewy

  Forum Editor 18:49 01 Feb 2006

I had one from them on test. I used exactly the same modem as you, and had exactly the same problem. Several calls to Belkin support served to tell me two things:-

1. Their telephone support is superb

2. The fault isn't with the router - they even sent me a second one to prove the point.

In the end I wanted to hurl the D-Link modem as far as I could see it, and I ran out of time and patience, so I abandoned the whole idea.

None of that helps you much, but sometimes it's good to know that you're not alone, and not stupid.

  keewaa 19:11 01 Feb 2006

Have you had everything working using the modem alone without the router? If not I suggest you do this first for one computer.

Might be an MTU issue click here

  yewy 19:23 01 Feb 2006

yes I have had everything working using the modem alone without the router. The MTU is set to 1492 using a PPPoA connection

  keewaa 09:28 02 Feb 2006

I would try setting the MTU to 1450 then 1400, just to check.

  keewaa 12:08 02 Feb 2006

Sorry ignore that MTU comment, it seems to be a common issue with that modem. Apparently setting the DSL300T to bridge mode,and letting the router do the PPPoE or PPPoA authentication has fixed it for others.

For further info type
dsl300t belkin
into google.

  yewy 17:06 02 Feb 2006

Thanks for that tip. Unfortunately my ISP is PPPoA not PPPoE and the router doesn't seem to support the PPPoA connection. Would any of the other 4 connections on the router be applicable to PPPoA?

  Forum Editor 17:29 02 Feb 2006

Try this:

select the option to use the following IP address, and enter

Enter for the subnet mask

and for the default gateway.

  yewy 18:16 02 Feb 2006

Thank you. I've just checked the TCP/IP properties but no joy.

  sagita 00:42 03 Feb 2006

I don't pretend to even understand the issues here. I am using a different modem than you, but my experience in setting it up yesterday may be germane.

I am on Tiscali like you and I first of all set up the modem to feed directly to the PC and configured it to suit the Tiscali requirements.

I then ran the set up wizard on the Belkin disk and having done exactly what it said, it all worked perfectly. On looking through the settings afterwards however I did notice that the connection type had been set to "Dynamic" rather than "PPPoA".

I thought that was wrong and swapped them and could not then get a connection - putting them back restored the connection. So it may be that while the modem needs to be on PPPoA to suit Tiscali, the router wants to be set to "Dynamic"?

Worth a try? I don't know, I'm an ignoramus, but I am talking to you now through a connection made this way :-)

My problems didn't arise until I got to my laptop and I will touch on that in a separate thread.

  sagita 18:57 03 Feb 2006

I received your message, but can't see it here on the board - probably just my incompetence at using it.

Sorry I wasn't clear. If you look at the guidance from Tiscali about connection protocols I believe you will see that it needs PPPoA, so that is what I have set on my modem. That is PPPoA and not PPPoE.

When going through the early part of the Belkin set up routine on the supplied CD I believe you should choose the Dynamic option rather than PPPoE.

I am saying all of this from memory and without the information in front of me so I will check and come back if I have mis-stated anything.

Good luck


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?