Problem adding network printer on Vista

  User-9A919F67-6ADE-4BFB-8B35A0F56CB2F7D6 17:06 15 Apr 2007

I am using a laptop with Windows Vista Home Premium and want to add a network printer which is on an XP Home desktop. When I try to add it, it is found and the name displayed, but when I click on "Next" it always says "Windows cannot connect to the printer, access is denied".

If I connect the printer directly to the laptop it works perfectly. Unfortunately the printer is downstairs and I use my laptop upstairs. Both PC's access each other and the internet wirelessly. I can transfer files between the two computers with no problem.

I have tried turning off both firewalls but this made no difference. I have tried downloading the latest drivers from Lexmark but again no difference.

This is obviously a permissions problem, but I don't know anything about Vista or where to start looking. Please help.

  tullie 17:08 15 Apr 2007

I know its a silly questio but,is your priner plugged into other computer and turned on?

:) Yes it is. Not that daft...... Yet !!

Just to add a bit more detail.

The printer is a Lexmark Z730 which is connected to main XP Home desktop via a USB cable. It is shared with a name of lexmark (not very original I know)

I have a second XP Home Desktop which is connected wirelessly too. This can print to the printer with absolutely no problems.

  BurrWalnut 18:47 15 Apr 2007

If you can see it in Network, try dragging its icon from the remote PC into the Vista PC's Control Panel, Printers folder.

I tried that, but after dragging the icon and clicking on "install" it just came up the same old "access is denied"

I just looked at the Event Logs. There is an "error" entry at the same time with a source name of "DistributedCOM" which has the following details

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
to the user Butch\Ian SID (S-1-5-21-2080295870-1996846180-1520653892-1000) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

It gives a suggestion but I have no idea what it means or how to do it. Any suggestions? This log is from the laptop running Vista (called Butch) and my account name is Ian


Has this got everyone stumped?


  magrat22 02:24 27 Apr 2007

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough fights back against sexual misconduct

WWDC history: Apple's product launches since 2005

Espace de stockage : comment libérer de la mémoire sur votre iPhone ?