This problem

  Forum Editor 23:02 16 Nov 2004

is usually the result of trying to publish from behind a firewall, or from a corporate network.

FrontPage needs to establish a two-way dialogue with an FTP server before it can publish files. In actual fact, FrontPage makes only one connection, and that doesn't permit file publishing. The FTP server makes a second connection back to FrontPage, and this is the one that allows you to write to the server directories. If you are behind a firewall it may (almost certainly will) prevent the FTP server from establishing the inbound connection - that's its purpose in life after all - and you'll get an error message.

The same thing will happen if you are publishing from a corporate network via an HTTP proxy server, and in this case you'll need to talk to your network administrator about an FTP gateway. If your network has a gateway installed you'll need to make some configuration changes:-

1. Open Control Panel.

2. Double-click Internet Options.

3. Click the Connections tab.

4. Click LAN Settings.

5. Click Advanced.

6. In the FTP and Port boxes, specify the protocol, the FTP server location, and the port number, for example:
click here server location:21


This isn't the place for a long discourse on FTP publishing from LANs however, and in any case I suspect that isn't your situation......my money's on the firewall solution. One thing you can try is to select the option (in FP) to publish via a Passive FTP connection - this means that there'll only be one connection to the server, which will allow you to write to the directories.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Book 2: Release date, price and specs

This First Man soundtrack vinyl cover art is exquisitely composed

How to watch Apple’s October 2018 iPad launch

Meilleurs VPN (2018)