Printer won't scan

  daveac41 22:41 07 Nov 2013

My Epson Stylus 435W has suddenly decided not to scan. It prints ok, the cartridges are all renewed. I contacted Epson , but they just directed me to their Q & A pages - not much help. The error message states "communication error", which can't be right, as I can print OK .I have re-installed printer, but still no joy.

Any ideas, please?

  Fruit Bat /\0/\ 23:33 07 Nov 2013

you need to uninstall everything to do with Epson


then reinstall the driver and software.

Also check Windows Imaging Service is started

  daveac41 00:45 08 Nov 2013

Hi FruitBat/\0/\/, Long time!

Tried the uninstal/reinstal but no difference. However, will try Imaging bit.



  woodchip 10:21 08 Nov 2013

After using Uninstall in control Panel, it leaves files on your PC that is where knowing what and how to look for comes in, so that you can delete them. as one file may have got the configurations on it, this is the one that needs removing as also Regedit will have settings in it, though you uninstalled these need to be removed before reloading drivers. Scanner Driver is different driver to Printer Driver. Name of Scanner Drivers are called Twain Drivers

  daveac41 11:06 08 Nov 2013

Hi FruitBat,

Checked Imaging Service - seems to be OK. States that it "provides image acquisition services for scanners and cameras" . My webcam is fine.


  daveac41 11:33 08 Nov 2013

Sorry Woodchip, missed your note. Am looking at it ASAP.


  lotvic 12:29 08 Nov 2013

You haven't said how you are initiating the scan.

Does anything on click here help.

  Fruit Bat /\0/\ 12:48 08 Nov 2013

Test the scanner by scanning and copying direct -

Another thing that might work is to Download and run USB device View

Uninstall ALL devices that are shown as not connected.

Reboot the machine.

Plug in your USB device and windows should then find new hardware and reinstall the drivers for the device.

1]: [click here

  daveac41 14:27 08 Nov 2013

Fruitbat, I tried ,as an alternative, to scan wirelessly.. Got same reaction. Photopcopying works OK.Will try USB Device view

Lotvic - I just followed scanning instructions,pressing the OK/Scan buttons via the printer's small instruction screen.

  Woolwell 14:39 08 Nov 2013

You should have Epson Event Manager installed on your PC. Open it, then Network Scan Settings check network scan settings is enabled and then try putting a new name in the box below.

  HondaMan 16:01 08 Nov 2013

OK. So you've tried everything obvious. What OS are you using? Try this:- Turn off the device and disconnect it from the computer Uninstall everything relating to that device.
Reconnect the device Restart the computer. The computer should come up with something like "unknown device" and then give you the option of installing the new software for it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?