Printer Will Not Work In XP

  Press Man 16:32 19 Nov 2004

Hi guys,

Help please. I cannot get my Canon S630 printer to work continuously? I have managed to print a test page, thinking all is ok, I try again, no joy. I have done a clean install of XP Home (full c/w SP2) reloaded all latest print drivers, enabled/disabled ECP in bios still no consistency in operation? I do not know what to do next! I really need to get this up and running reliably for my daughter to do her college documents. Thanks in advance of your help.

  Fruit Bat /\0/\ 17:00 19 Nov 2004

Try Cannon support for this printer click here

  Press Man 17:27 19 Nov 2004

Fruit Bat /\0/
Link does not work? "Page cannot Be Found".

  VoG II 17:33 19 Nov 2004
  chub_tor 17:36 19 Nov 2004

s630 support page here click here

  alnwrd 18:48 19 Nov 2004

Could you try this printer on another pc? It may be faulty

  Press Man 21:37 19 Nov 2004

Already tried these drivers with no luck??

Still cannot get the support page from the link??

Tried it on my sons laptop, worked right away??

  woodchip 21:54 19 Nov 2004

In BIOS set to EPP/ECP

  chub_tor 22:48 19 Nov 2004

I got the support page by googling "Canon s630 printer support" and it came up straight away, however you are correct that when I click on the link it says error on page. You might try the google.

  Wilham 23:36 19 Nov 2004

May not help but here are some quick checks.
(i) Click 'Start', then 'Printers and Faxes'. Now check you see icon of your printer with a tick to show it is set default.
(ii) If usb drive, try another PC socket/port in case there's contact damage.
(iii) Pull out the cart. check there's ink and replace. If it then just prints half page and runs dry and you've used compatible carts, check there isn't surplus sellotape/price tag/ or similar stuck over a breather. The setting on the other PC may be economy and so not outrun the ink flow.

Just some ideas.

  Press Man 00:02 20 Nov 2004


Thanks for the ideas, but I think the problem lies either with the driver setup or the printer itself? I have now got latest drivers, had ecp/epp & ecp set. Managed to print test page "almost complete" in both modes. Try a second or third time and all I get is status monitor saying "checking printer status" and the green light flashing on the printer? Another time it will say "on line" but nothing happens??
This is starting to dive me "mad".

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)