Printer stopped working, can't reinstall

  songbird72884 12:55 04 Nov 2012

I'm running Windows 7 Home Premium 64-bit and recently started having a lot of issues, all at once. In the space of about 2 days, printer stopped working, my computer slowed down dramatically (from a boot time of about 1 min to more like 20 mins) and began freezing/ crashing at random intervals, and sometimes booting to a black screen.

However, I seem to have managed to solve the computer issues, but the printer issue remains. I have an HP PSC 1402 All-In-One printer which, until now, has worked without a problem. Withtin the last few days, it's gone from problem-free to rife with problems. An example of the typical scenario is as follows (including unnecessary but possibly useful preamble):

-I plug in my printer to the computer (it's a USB one and the cable is very short so I have to only connect it when needed) -The usual 'installing Device software' icon appears in the bottom right corner, as it does with every USB-connected peripheral. -A red circle with an 'x' appears, at which point I click it, only to find the error 'HP PSC 1400 Series ....... X Failed' -I go to Devices and Printers and click 'Add Printer' and an error pops up stating that the operation cannot be completed because the print spooler is not running. It asks me to restart the spooler or restart the computer. (I've tried both, but for purposes of explanation, I'll continue with what happens in the first instance) -I go into the Services menu and right-click the Print Spooler and click 'Start', at which point it starts without issue. -I click on 'Add Printer' again, and this time receive an error with code 0x000006be, stating that the Add Printer operation can't be started

The problem is that I've downloaded the drivers from the HP website, restarted the spooler, restarted the computer, checked for viruses, cleared the 'drivers' section (as suggested on another tech site) and never seem to be able to get this sorted. I can't think what is causing the problem, but it's driving me nuts.

Is this more likely to be a problem with the computer, the software, or the printer? And is it likely to be solvable or should we resort to buying a new printer instead?

  northumbria61 14:18 04 Nov 2012

Take a look here enter link description here

  songbird72884 17:11 04 Nov 2012

After reading that tutorial that you linked, I noticed that a few of the registry entries listed in the post were missing. I clicked through to another page which listed entries that needed to be merged into the registry because default drivers were missing, however that was for Win XP. Is there a way to check whether there are entries missing and to add them where needed in Win 7? I'm not too familiar with the driver side of things, so I don't really know what I would need to search for, nor how to utilise it once I found it.

Thank you so much, by the way! I hadn't been able to find the same scenario anywhere, so that link was very helpful

  spuds 11:08 05 Nov 2012

A few points:

When unplugging and re-plugging in the printer, do you use the same usb socket, because sometimes, using different sockets from those originally used can bring possible problems.

The other point is the driver you are trying to install. Have you checked with the printer manufacturer services, to see if another driver is available for installation purposes?.

Regarding the cable, these are fairly cheap, and come in all sizes, so in reality there should be no reason to keep un-installing the printer. Have you thought about this?.

  Fruit Bat /\0/\ 19:21 05 Nov 2012

Remove all USB devices except keyboard and mouse.

Download and run USB device View

Uninstall ALL devices that are shown as not connected.

Reboot the machine.

Plug in your USB device (printer) and windows should then find new hardware and reinstall the drivers for the device.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts