Printer only printing Word documents

  Duncanf 13:26 05 Feb 2007

I've just had to replace my printer and am now using an Epson Stylus C42UX. After downloading the relevant driver it's working fine with all documents in Word but refusing to function when I offer it printing from Publisher items or any web pages unless I cut and paste them into Word. Am I missing something simple? Thanks again in anticipation of the Forum's help.

  Alan H E 14:00 05 Feb 2007

Is the new printer showing as the default printer? If it is try reinstalling driver.

  Duncanf 14:48 05 Feb 2007

Thanks, Alan H E. It is the default printer and I've just reinstalled the printer and driver yet still no joy!
Thanks anyway....maybe something else will turn up!

  provider 2 15:02 05 Feb 2007

Just a stab un the dark, Duncanf, but have you brought up the printer`s configuration page to see if it`s configured to print offline?

  Alan H E 15:18 05 Feb 2007

Do you get any message when trying to print in Publisher or OE? Will it print from Wordpad or any photo app?

  recap 15:22 05 Feb 2007

Check in Publisher that the Printer is present. Go to Tool/Options/Print and make sure that your current Printer is showing. If not open up PageSetting select the printer then Properties and check the Default button.

  Duncanf 17:03 05 Feb 2007

Thanks to all for suggestions. Just come back in! Alan H E...I'm on Mozilla Firefox but no message appears when trying to print from Mozilla or Publisher. All that happens is that there is a queue of documents building up to be printed!
provider 2 ....not sure where to find the printer's configuration page.
recap...Printer is the default printer in Publisher.
Will keep trying!

  Kingfisher 17:45 05 Feb 2007

you could try cancelling all documents in printer properties, my own epson r300 just does nothing if there is a big queue,I think it is waiting for the print spooler to amagamate all th info which could take a long time if the files are big. then try printing a test page

  Duncanf 18:31 05 Feb 2007

Thanks, Kingfisher...the only items that are going into a queue are the non-Word ones and I've left the printer for over 10 minutes with one in the queue!
I tried a test page at the beginning and it told me the printer was correctly installed.
It's a strange one! Thanks, anyway.

  Duncanf 00:16 06 Feb 2007

That's it fixed!!!! Although I had ticked the Epson C42 as the default printer I hadn't deleted the Epson 600 in the Printers/Faxes page. As soon as I did, it resumed printing Publisher and Web pages. Thanks everyone!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?