Printer Epson D92 Communication

  modsteve60s 14:56 07 Jan 2009
Locked

Hi
I have tried to use my printer for the first time since Christmas and there seems to be a problem. It doesn't work an comes up with something saying communication error.It was working fine before Christmas, the leads all seem secure. I tried uninstalling the previous software and downloaded new drivers from the Epson site to see if that would work; it didn't. I've tried shutting down the computer and turning it on, I've unplugged the wires from the printer/computer..nothing seems to work. I am working from a Vista laptop. If any of you clever people out there can help I would be grateful.

Thanks.

  modsteve60s 15:37 07 Jan 2009

j

  modsteve60s 17:04 07 Jan 2009

Just wanted to add there is no red light showing, but the green one stays lit all the time.

  Woolwell 20:27 07 Jan 2009

Sounds as if it is a cable or USB port problem. Try a different USB port.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Sam Falconer transforms science and geology into digestible, elegant illustrations

HomePod review

Les meilleures séries Netflix (2018)