Primary Slave Drive added but 'drive fails'

  User-316DD552-F004-44A5-9F4DCDAA73F4C9E3 22:10 03 Aug 2003

I have added a WD primary slave drive to my WD master drive. All jumper settings are correct - have tried on both master and slave and CSEL jumpers - both work. Both drives register in bios on auto setting. Both drives show up in device manager. Fdisk will not recognise second drive on system and neither will 'Data Lifeguards Tools' supplied by WD - therefore cannot partition or format slave drive. On boot up I get 'primary slave drive fails' message. OS is ME. Size of slave drive 120GB. Pulling my hair out - anything would be FAB!

  Philip2 22:34 03 Aug 2003

Your WD primary master should have no jumpers set
only the slave,what size have you upgraded from??
does your new drive work if set up as master??
I had a problem with my WD 80gb but it showed up as an error and mine was replaced if you put it as i said to master use the floppy to set up the drive you should be able to write zeros to the drive if it still doesn't work you could have a duff HD.

Original drive is a 40GB and new drive is a 120GB. Thanks for the suggestions Philip2. Tried the master with no jumpers but neither drive would load at all. Then tried detaching the original drive and jumpering the new drive as a single drive present on the system - both as single drive and as CSEL jumper settings. Boot reported drive failure and fdisk reported 'no fixed disks present'. Am beginning to wonder if you are right and I simply have a duff second hard drive (just purchased as new - OEM). Anyone else has any suggestions (even if to confirm duff drive suspcions or to offer alternative strategies) they would be much appreciated before I get in touch with drive suppliers. Thanks.

  powerless 23:38 03 Aug 2003

Master with slave and slave are you sure the jumpers are set to this?

  Philip2 01:40 04 Aug 2003

Strange as i said the drive you are using as master should have no jumpers connected as per WD if there is more than one drive on the cable if there is only one on the cable the jumper should be set as shown on the drive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Comment utiliser Live Photos ?