PowerLink speed: going, going... gone!

  Tom K Hawkey 13:46 02 Apr 2018
Locked

Hi there,

I have recently moved into a new flat. My bedroom is the only place where there is a WiFi blackspot. I've bought a BT Essentials WiFi PowerLine 500 Kit to try to fix the problem. Initially, it seems great - connects up fine and when I run a speed test, my phone gives me speeds of around 35mb/s (which is a shade under what I get if I run the speed test when connected to the main router). However, when I then run the test again, it has already dropped to around 10mb/s, then drops again and hovers at around 3-5 mb/s.

Is there something obvious that might cause this? Is the main router somehow choking the speed? It seems strange that I can get such a high speed before it then plummets and bottoms out at a fraction of that speed.

Any advice is would be greatly appreciated!

  Tom K Hawkey 14:05 02 Apr 2018

Update: I just logged on to the Virgin router, and it lists the PowerLink as a connected device with a speed of 1000mb/s, so it doesn't look like it is restricting it at all. I also plugged the PowerLink transmitter into the same room as the router. There was a similar results, though with a better bottomed-out speed (initial reading was 40mb/s, bottomed-out speed was between 10 and 12mb/s)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Google Pixel 3 review

Automatically create thousands of unique variations from one original design with this Illustrator…

iPhone XR release date, price & specs

Test : le Razer Phone 2