SANAP 23:46 04 Jun 2010

I tripped the power points, dont ask, that had my desktop connected, on laptop now, and when I
went to power back on saw flashing orange light at front, pulled out plug at back and waited a few moments, power is on as I have a surge rpotector and a few greens light are visible inside casing but when I press power button I get nothing!! This has happened with power cuts before and always poewred back on. Is there a fuse blown that I am not aware? Or...



  birdface 23:56 04 Jun 2010

Have you tried switching it of from the electrical socket and leaving for 10 minutes before trying again.
No fans starting or bleeps could maybe make it a PSU problem.Not sure about the motherboard.

  SANAP 00:24 05 Jun 2010

i did, i also tried a trick with jumping the 24 pin supply from motherboard, i'd say its the psu and i did have grief a while back. I wonder why the tripping tipped it over? will try again in morn.


  birdface 01:04 05 Jun 2010

Was that connecting the green and black wire with a jumper.
At least i think its green and black.
That usually tells you it is the PSU if my memory is still working.
Anyhow best of luck.
Will see how you get on.

  Fruit Bat /\0/\ 10:01 05 Jun 2010
  woodchip 12:10 05 Jun 2010

To test if its computer or Hard drive, Disconnect plugs from Hard Drive with Power off. Then switch on to see if it will go to BIOS or show anything on screen without hard drive connected

  SANAP 15:44 05 Jun 2010

back again, I did the jumper trick and nothing happened, ie fan did not start. Can I assume it is the PSU now??


  woodchip 16:48 05 Jun 2010

have you tried without hard drive connected as this can stop it starting

  karmgord 18:11 05 Jun 2010

have you checked the obvious,
fuse in plug OK and that the power lead is firmly pushed into PSU
Don't be insulted but sometimes the obvious is overlooked

  Diemmess 18:31 05 Jun 2010

Another trick might just help, but you do have to pace yourself and let whatever will be....

Shut down and switch off at the wall. Then press and hold the reboot button for at least 30 seconds.

Now switch on at the wall and try a normal startup.

It may not work, but it puts some order back into a chaotic situation and is worth a try.

  SANAP 19:45 05 Jun 2010

thanks all, tried all of the above and zilch, nothing, all I have is a green light inside when I power on. I even changed power leads and power points!!

i hope its psu as a MOBO is hard to come by apparently.

this is the PSU I intend to get,

click here


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?