Power surge on hub Port

  swanny2 17:07 05 Oct 2008

ive just been too connect me camera,as usual but i get a message saying Power surge ob hub port has exceeded its limit? no ideas it worked b4.
Had a option too close hardware an repair so i disconnected camera pressed repair nothing happened. only same message when i rebooted.
Any ideas any1 please.
Swanny :O)

  swanny2 20:18 05 Oct 2008

few months ago i had a 4 port thing put in the back of me pc becuase the 2 front ones wont work , 2 in the back do work.
Now ive plugged me keyboardan mouse in both usb Portsmmbut if i try me digi cam it wont work, ive disable the pop up sign Power surge on usb ,but it still wont work me camera.

  swanny2 19:03 06 Oct 2008


  tullie 20:15 06 Oct 2008

Cant understand your thread fully,i take it that youve plugged camera into usb port,but windows doesent detect it,is that right and have you tried another device in that port?

  swanny2 20:44 06 Oct 2008

yes mate exactly . ive tryed me keyboard etc. they work .

  tullie 20:52 06 Oct 2008

What happens if you turn camera on then plug it in,any response from windows?

  tullie 21:29 06 Oct 2008

Have you tried it with the cameras software installed?Though you shouldent need it.Anyone else got any ideas?

  swanny2 21:37 06 Oct 2008

ive tryed the canera in the 4 port holes where i have mouse etc still wont work . the software is already installed.
still get the nessage power surge. when i clik on the pop up i get 5 ports unused ? an 1 has a yellow question mark saying uknown device. ? baffled lol.

  tullie 21:55 06 Oct 2008

Have you gone to device manager,uninstalled any reference to usb,then rebooted,windows will reinstall,im clutching at straws.

  swanny2 22:28 06 Oct 2008

i went 2 device mmanager but no yellow marks there went too clik on ports an all it says is communication ports 1 and 2 comm 1 comm 2 then printer por(lpt1)
tryed update drivers on them still the same.

  swanny2 12:40 07 Oct 2008

This is weird i had another go at trying my cmmamera in the port that the keyboard was in and it Worked.didnt work b4. ogh well upto now seems ok . thanks for help..

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

How Sketch and InVision have revolutionised our design workflow

The best tech gifts for Christmas 2017

Les meilleurs jeux de société (2017)