Power Supply/Motherboard/Virus Combination???

  Gaz W 01:07 30 Jun 2004

I've had trouble recently with an Antec TruePower 430W power supply. More details on the original problem are here: click here.

Basically, the PSU went back to Micro Direct, where they tested it and said it was working perfectly. I've used it for less than a week and it's just happened again tonight, so I'm back on my reserve power supply again.

Last time I reset my CMOS (removed the jumper) because I didn't think the power supply was the problem, so I wasn't surprised when I got a CMOS Checksum Error on bootup (with my reserve PSU).

However - it's happened again this time after replacing my power supply when I haven't even reset the CMOS! This made me start thinking it was a motherboard problem (well it is near the end of its warranty), but then I remembered that the exact same thing is happening on another PC on my network (CMOS checksum error on EVERY bootup) - I was going to replace the battery on that one but didn't get round to it.

I only thought it might be a virus because of it happening on two PCs - AVG doesn't find anything and it's up to date. I did think it would be more likely that this stupid Antec power supply is damaging my motherboard!!!

My PC's specs are:

Antec TruePower 430W (usually)
Abit AT7 Max2 motherboard
AMD Athlon XP 2600+ (333MHz FSB)
512MB DDR 333
ATi Radeon 9800 Pro 128MB
250GB Western Digital Caviar SATA HDD
Artec DVD-ROM drive
Samsung CD-RW
NEC DV-2510 DVD writer
Akasa neon light

I think that just about covers everything in there so it should give a good idea of my system. Any ideas what's going on here?

  hugh-265156 01:39 30 Jun 2004

is the time and date correct in the bios or are all settings reset?

i would try a new battery as it will only cost you £1.50 or so, so you have nothing to lose really by trying this. most mobos i have seen use a CR2032 battery by the way.

  Gongoozler 06:37 30 Jun 2004

I may be wrong, but I don't think a checksum error is caused by the CMOS battery or settings. My understanding is that a checksum error is caused by defective or corrupt BIOS.

  Gaz W 15:22 30 Jun 2004

Right - the date and time, basically everything in the BIOS, was reset to the default values as if I'd reset it. You are correct huggyg71 - it is a CR2032 battery which can be replaced easily enough. The only thing is - I thought motherboards recharged this battery while the computer was on! I have an Amstrad from 1992 still on its original CR2032 battery. When it goes flat I just switch it on for a while and it's OK after that!

I believe the checksum error is because it goes back to the defaults, which are something like an Athlon 1GHz or something stupid with DDR 200 memory clock, when I have an Athlon XP 2600+ and DDR 333. When I change it all, it's alright again. I'm using the computer now in fact.

Could it be in any way related to the Antec power supply? I've not had any problems with this old power supply I'm using now (cheapo 550W dual fan), other than it not being good enough to power everything without the neon light flickering! Still it works, and I've not had the computer freeze with this PSU installed.

When it happened yesterday, I immediately tried my old PSU and it worked. I then tried the Antec again, and got the same problem. It seems to power everything apart from the 3 optical drives at the front, and nothing appears on the display. Oh, and no beep.

  hugh-265156 16:23 30 Jun 2004

even rechargable batteries have a limited lifespan. mobo batteries should last around 3 - 4 years on avg but may last a week or 10 years, just depends.

if the bios settings are reset after shutdown and restart then it looks most likley that the battery is the culpret here but the only way to check is to replace it.

  Gaz W 16:43 30 Jun 2004

Latest update - AVG found a virus I've had for 2 days now (Hantaner.A) - doesn't do anything, but it was in the System Volume Information folder, so AVG couldn't access it until I changed the permissions temporarily! Unless that virus causes problems with the BIOS I don't think it was that, but I might as well check anyway.

As for the power supply, it's going in for extensive testing - bet nothing goes wrong!

  Gongoozler 17:14 30 Jun 2004

The CMOS battery doesn't recharge. It is being discharged all the time the power to the computer is switched off, so the more you use your computer the longer the battery lasts.

The Hantaner.A virus targets Kazaa files click here.

I have now found that my earlier comment was wrong. A checksum error can be caused by a low battery click here.

  Gaz W 17:15 30 Jun 2004

It's definitely not shutdown and restart - it only happened after the PSU incident; since I've changed it all back to my settings & saved it's been fine. It worked this morning when I switched on; I think the other PC is a battery problem as I mentioned.

  Gaz W 17:20 30 Jun 2004

I realise that the battery is running down when the PC is off, but I was under the impression that the battery is actually recharged when the PC is on, which has been proved with my Amstrad. I switched it on for the first time in ages the other week and the battery was dead. I entered everything into the CMOS Setup again and left it on, and it's been OK ever since. The battery on it is 12 years old and this has only ever happened about 4 times.

I assumed it would still be the same with more modern PCs - maybe not.

I found out what Hantaner.A was - I actually remember downloading it but then AVG wouldn't detect it. I have now managed to get rid of it, but needed to give myself access to the C:\System Volume Information folder - stupid really - surely an antivirus program should be able to access things where SYSTEM is in the permissions?

Anyway I've got rid of it - I should know better than to use KaZaA for anything - it's rubbish anyway!

  Gongoozler 19:23 30 Jun 2004

Hi Gaz W. The batteries used to store the CMOS settings in modern computers are non-rechargeable Lithium cells. At a guess, I think the old Amstrad CMOS cell may have needed to be rechargeable if the memory devices used to store the BIOS settings used more power than the modern ones. Generally the lithium cells these days last for several years, and a rechargeable cell would probably not last much longer than the lithium cell.

  Gaz W 19:30 30 Jun 2004

That's something I'll have to watch out for if I ever have to replace the battery in the Amstrad (it is a CR 2032 I think). Anyway, the BIOS seems OK at the moment - I think that it might have somehow been triggered by the faulty PSU. Given that these batteries aren't rechargeable, it can't be the battery that's the problem.

For now, what I'll do is leave the computer on again and see if this blank screen problem does happen with my substitute PSU.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Amazon Echo: What’s the best Alexa speaker?

Kano Computer Kit Complete review: A fun DIY 'laptop' that teaches kids to code

Best pro photo editors for Mac 2018

TV & streaming : comment regarder les Jeux olympiques d’hiver 2018 ?