portable usb DVD RW problems

  dkny121 14:01 30 Apr 2017
Locked

hi guys i bought a USB dvd RW for my laptop and installed it windows 7not a problem went to format the disk and not its saying on all disks including blanks that they are full 7.8gb and there only 4.7 and when i open it on explorer it says there is no files im unsure what ive done and was wondering if someone can help me please thank you

  rdave13 19:39 30 Apr 2017

Not sure of your problem as the drive doesn't need to be installed as Windows will see it as an optical drive. Try booting the laptop with the optical drive already connected to the USB port. Does Windows now see it as a drive? If it doesn't work - shutdown, remove the drive from USB then reboot. Wait for Windows to settle on the desktop and then connect the drive. See if Windows picks it up then.

Is this a Powered DVD drive or does it get its power from the USB port?

  dkny121 20:10 30 Apr 2017

yes its powered from the usb with two cables im normally quiet good with computers and so forth but im totally puzzled... before i got this drive yesterday i was using iso buster and power iso for different things as the current disk drive is broken... i tried to format the disk on my computer right click drive and format and then it came up with the file system saying UDF and that the disk are totally full even on blank disks on the new drive as needed a fresh disk for work and now im unsure what to do to restore it correctly please

  rdave13 20:20 30 Apr 2017

If you've still got the installer.exe for both programs in your download folder then try uninstalling them, reboot and see if the drive recognises an empty DVD/CD disc. If OK try cdburnerxp free to see if you can manage RW discs.

  dkny121 20:29 30 Apr 2017

ive just popped a genuine disk in full no space went into my computer double clicked it and it saying there is no files at all on the disk but poweriso freezes when try and view the genuine dvd disk ive just swapped over to a RW disk full again but this one is same as above but needs formatting and upon MY computer it says 7GB full..FILE SYSTEM UDF 1.50 or UDF 2.00 or UDF 2.01 OR (default)OR UDF 2.50 allocation unit size default allocation size or 2048 bytes but the format options both quick format and create an MS-DOS startup disk both not available to be ticked

  rdave13 00:04 01 May 2017

but poweriso freezes

Try uninstalling these apps then reboot. As posted 20:20 30 Apr 17.

  dkny121 11:56 01 May 2017

tried it still says udf

  rdave13 12:12 01 May 2017

Can you try it on another PC just in case the drive is faulty? Also check in services that Shell Hardware Detection is started and on automatic. It should be plug and play and I'm running out of ideas.

  dkny121 12:36 01 May 2017

ok il try it soon as get home as not got drive with me at the moment

  Forum Editor 12:39 01 May 2017

UDF (Universal Disk Format) called 'Live File System' by Microsoft, is a file system that was developed to ensure consistency across various types of optical media.

You do not need to format a UDF DVD.

Did you get any driver software with the drive?

  dkny121 12:47 01 May 2017

nope it was just a simple plug and play device ive uninstalled the usb and reinstalled it and it still coming up underneath the drive UDF no matter what disks i put in both dvds and work file dvds and blanks still says UDF

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Google Home Hub review

This graphic novel uses AR to blur the lines between cartoon, comic and video game

How to watch Apple's October 2018 iPad launch

Comment désinstaller des applications sur un Mac ?