Portable HDDs not seen on Windows 7 64bit

  Podracer 22:20 26 May 2012

I have a brand new Windows 7 64 bit computer, and want to transfer files from my old Windows XP computer to the new Win 7, using Freecom portable hard drives. I have two such drives each of about 80GB, and both work perfectly with the Win XP computer. However, when I plug them into the new Win 7 machine, although I get the "drivers installed correctly - you can use your hardware" (or similar) message, neither drive will show up in Windows Explorer - so I cannot access any files.

However, smaller capacity (eg, 2GB) pen drives do work fine.

I have tried a couple of fixes as recommended by quite a lot of threads on various websites (inc the PCA Helproom), but all to no avail.

Any thoughts? I wonder if it is because the drives are formatted for a 32 bit computer (Win XP), and thus can't be seen by the Win 7 computer. But then, if I do re-format them for the 64 bit, how can I use them on the XP machine....???? (and can the Win XP computer re-format them for 64 bit???)(and why do the pen drives work??)

Incidentally, the Freecom drives seem to be rotating when plugged into the Win 7 machine, as there is a little vibration coming form them, but even waiting for almost 10 minutes, nothing seemed to happen.

Thanks in advance for any suggestions.

  rdave13 22:30 26 May 2012

Try connecting one drive to the PC then boot up. If the external usb drive has a power unit then make sure it is on before you boot up.See if that helps.

  robin_x 22:36 26 May 2012

Drive format is nothing to with the OS 32 or 64.

Have a look in Windows Disk Management (Start search diskmgmt.msc).

The drive letters may have clashed.

You can set again by right click Change Letter if so.

say F: and G: or whatever are free.

  Podracer 20:52 27 May 2012

Rdave and Robinofloxley - thank you for your advice - in fact all overtaken by events. It was late last night, and I did nothing. However, when I turned the computer on today (with the portable HDD not connected), and then plugged it in to see if it worked, it flashed up straight away. The ways of computers are curious, but once again that old adage of turning off and on (albeit with a 20 hour gap) seemed to work. Thanks anyway.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Majority of illustrators don’t earn enough to live from, new survey shows

iPhone X problems

Word gratuit : comment télécharger le logiciel de Microsoft ?