Poor connection/patchy functionality

  RyanHurst 19:34 31 Mar 2014

Hey, thanks for reading.

I noticed a week or so ago that the connection quality of my Wifi was consistently lower than normal, and the speed was down to 10-20% of normal. Nothing had changed with hardware or location of the PC or router. After a bit of messing around, I went with a new network adaptor (USB). This improved the quality of the connection, which is now always "Excellent", never drops out.

However, there have been other issues since fitting the new adaptor. Websites don't load fully, videos don't always load or playback is suddenly halted, pictures are half-loaded and so on - kinda like you'd expect packet loss to look maybe? The speed has improved to it's usual state (~19mpbs down, ~1mbps up).

Re insterting the old adaptor doesn't change these half-loading problems. I borrowed a friend's Netgear adaptor and that also didn't help.

I'm running a self build from 2009ish, running Windows 7 Pro 64 bit, sat around 20 feet from my router, which is the UK Sky Hub SR101.

I may be an idiot that's missing something obvious, who knows. Any help greatly appreciated.

  Fruit Bat /\0/\ 19:52 31 Mar 2014

If you have tried another router then fault is line or PC

Does phones tablets etc. work OK on your connection?

if these are bad as well then its probably the line try the router in the master socket if on an extension. if still same call your service provider and ask for a line check.

  RyanHurst 20:20 31 Mar 2014

There is a Windows phone, 2 Android phones, an Android tablet and a couple of Windows laptops connected, and working fast and fine. It has to be my PC, software or hardware I suppose.

I'm well stumped.

  Fruit Bat /\0/\ 20:29 31 Mar 2014

Try uninstalling and reinstalling the wireles drivers.

is it the same with a ethernet cable plugged in?

  RyanHurst 20:38 31 Mar 2014

I've reinstalled the drivers for both adaptors and tried other drivers than the standard as well, to no avail.

Just tried it connected via ethernet, all works fine. So it must be the wireless hardware/drivers I guess?

Weird though, that it didn't half-load stuff etc with the original adaptor, then started doing it with the new one - and now also does it with the old one.


  Fruit Bat /\0/\ 20:57 31 Mar 2014

Are these USB wireless adaptors?

If so try refreshing the USB ports

  RyanHurst 22:12 31 Mar 2014

Refreshing the root hub does seem to have improved things, still not perfect though. Thanks a lot for your input, much appreciated.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?