Plug & Play Installation Error

  tallboy 10:03 19 Oct 2003

I am trying to add an Ethernet card to my Mesh Athon PC which runs under Windows 2000, since I now have a Alcatel Broadband router to connect three PCs to the Eclipse Broadband service.

After plugging in the card I get the usual 'Found New Hardware message, but then get an error message: "An error occurred during the installation of the device. The data is invalid."

The card I am using is a Intellinet PCI 10/100 network card and uses the RTL8139.SYS driver. I have also used a no-name card (which uses the same driver) and I get the same result. I have updated the driver to the one that comes with the card (rather than rely on the one in Windows 2000) but that didn't help.

Any ideas as to how to get it working would be much appreciated.



  LastChip 11:29 19 Oct 2003

First, if you have an alternative slot, go into device manager, remove the card from there, close the machine down, remove the card and reinstall in the new slot. Try again! (It may be an IRQ conflict).

Alternatively, you could go to click here and download the latest available drivers, but note you will need to find out which series you have, as there are three alternatives.

I am surprised you are having trouble with this, as Realtek cards are normally trouble free on installation. In fact, I use them myself on a W2K based machine.

One other thing that springs to mind, don't connect the card to anything other than the motherboard. All connection and configuration to the network, should be carried out after a successful installation has been achieved.

  tallboy 21:03 01 Nov 2003

I've tried two different slots and two different makes of Ethernet card - but still end up with the same error message. However, I have at least got as far as where it asks for the installation disk. In both cases, nothing has been connecetd to the card.

Any other ideas would be most welcome!

  LastChip 21:16 01 Nov 2003

Have you tried bypassing the pnp hardware recognized part by clicking cancel, and then install manually via Add/Remove Hardware, pointing the Wizard to the correct drivers?

  LastChip 21:51 02 Nov 2003

"I have tried removing the hardware (using the add / remove facility provided by Microsoft) and then re-installing it with the trouble-shooter in add / remove. When it gets to the point where it asks for the driver, I have let it search the Microsoft driver database for a driver. It comes up with, what it claims as a better driver - but I still end up with the same 'Data Invalid' error message!

Any other ideas are most welcome."

Could you please keep your comments to the thread, as someone else may then read it, and offer you an answer.

Can I suggest you get rid of all traces of previous attempts as above. Try again via the manual install route, but this time, point the Wizard to the drivers provided by the manufacturer, presumably on a floppy. Microsoft like to believe their drivers are the best solution, but it doesn't always hold true.

  woodchip 22:05 02 Nov 2003

Have you tried turning P&P off in BIOS and let Windows P&P sort it

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Nvidia’s Gaugan tech turns simple colour blocks into realistic landscapes

New AirPods 2 launch: Release date, price, features & specs

AirPower : date de sortie, prix et fiche technique