Pentuim M speed issue - stuck at 600MHz

  NinkyRudes 11:26 15 Apr 2008

I wonder if anyone can help, I have searched across the net on this issue but none of the suggestions in any other forums work:

My parents own a Rock Pegasus T4, bought several years ago based on a review in the magazine. I visited them last week and on investigation found that the 1.7GHz Pentium M processor is locked at 600MHz with a multiplier of 6 (should be 17) at a FSB of 100MHz.

I am aware of Intel Speedstep and other BIOS settings that affect throttling as I am an overclocker myself. However, there are simply NO options in the BIOS to do anything other than change the time and a couple of other mundane functions.

I have tried everything I can think of, playing around with the power saving options, dowloading and installing [url=click here]SpeedswitchXP[/url] to no avail. The processor is being locked at the power saving multiplier by some evil force within XP (Home) or at hardware level.

Interestingly, during POST the system even reports "CPU Speed = 600MHz", although it also correctly recognises the rated speed as 1700MHz.

I would normally just nip into the BIOS and disable the various C1E, EIST etc options to eliminate those, but without access to them I am blind.

Any suggestions? Please help me speed up my folks, they need it!

  I am Spartacus 12:05 15 Apr 2008

If you enable Speedsetp do you get any options to set for Maximum Performance on Mains/Battery Power?

  NinkyRudes 12:30 15 Apr 2008

Sorry if I sound thick, but when you say "enable Speedstep" what do you mean? Is there an option within Windows to enable this?

I tried setting the laptop to Home/Office Desk in the power settings (with the thing plugged into the mains).

The other options are:

Always On
Minimal Power Management
Max Battery

I must be honest and say that as an avid desktop user I rarely venture into power saving modes so don't know much about them!

  I am Spartacus 12:31 15 Apr 2008

It will be a BIOS setting.

  I am Spartacus 12:33 15 Apr 2008

Anything under Advanced, CPU Features?

  Simsy 12:43 15 Apr 2008

"but without access to them I am blind." Do you mean you don't actually have access to the machine, to see if there are appropriate settings in the BIOS? I think you do mean that...

Possibly the multiplier is set by a jumper on the mobo, that has either been misplaced, or come adrift? I'm pretty sure that my first PC mobo had the multiplier set this way.

Obviously if this is the case it would probably/possible mean that it's been running at this speed since new. Is this possible?

Sorry I can't help any more.

Good luck,



  NinkyRudes 12:44 15 Apr 2008

Unfortunately not. The BIOS is provided by Insyde Software, a customisable BIOS solution, and it seems Rock have taken it and cut out support for most of the options available using the Intel 855GME!!

I think I am going to struggle on this one. I can't honestly remember whether the laptop ever ran at full speed but I'm sure it must have.

Unfortunately, resources on the internet are very poor for this product, leading me to believe that sales were not great, which often makes it much harder to find anyone else with the same model.

  NinkyRudes 12:52 15 Apr 2008

Simsy - good points! I still use an old VIA motherboard with jumper controlled FSB, and this is worth looking in to. I'm not there right now but will take a peek next time I am able to.

Failing that, I'll have to brave (and probably pay for) technical support....

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Sam Falconer transforms science and geology into digestible, elegant illustrations

HomePod review

Les meilleures séries Netflix (2018)