Pen Drive

  BIGXXH 14:45 16 Feb 2012

Please could somebody tell me how to get a pen drive out of write protection every time i try to delete something from the pen drive it says it's write protected. and it gives me this file which i can't find.


                      Thanks in Advance

  Fruit Bat /\0/\ 15:42 16 Feb 2012

There is often a very tiny slide switch on the stick that needs to be operated.

Make and model?

/device/hardisk5/dr12 is just the designation of the stick as used by disk managment.

  BIGXXH 19:15 16 Feb 2012

Don't know the name or model as it's one that's given out to customers of a company as advertising but i put my photos on it and can't get them of. there's no switch on the side or any thing of that nature.

                       Thanks BIGXXH
  lotvic 21:07 16 Feb 2012

Are you trying to delete the photos on the pen drive or copy/move them to your pc's harddrive?

If you rightclick on one of the photos and choose 'properties', is the photo marked as 'read only'?

Have you tried drag and drop?

It might be good idea to copy the photos to your pc's harddrive and then try formatting the pen drive.

  BIGXXH 10:04 17 Feb 2012


when i right click on photo and go to properties it is ticked (archive) would that have anthing to do with it. I have tried to transfer to hard drive they go to the hard drive and are stored but they are still on the the pen drive so i have two lots and i can't use the the pen drive to store anthing else.

                           Thanks BIGXXH
  Fruit Bat /\0/\ 10:24 17 Feb 2012

If you're absolutely sure there is no switch anywhere on the stick - try formatting it.

  lotvic 11:58 17 Feb 2012

Agree with Fruit Bat /\0/\, if you have copied your photos so you don't lose them - try formatting the pen drive.

My pen drive has FAT file system (my TV can't read NTFS so have left it is as FAT which is what it came with so that I can view things on telly). Don't know what file system is best for you to try to format to, Fruit Bat /\0/\ will prob know.

What Op Sys do you have on your pc? W7 or XP?

  lotvic 12:08 17 Feb 2012

I had a look at properties of another of my pen drives and it is FAT 32 file system.

All the files on both pens are ticked for 'Archive' and I have no problem deleting etc. so that can't be what's stopping yours.

  BIGXXH 12:45 18 Feb 2012

I have tried formating the stupid thing and it say cannot format as it's write protected what is that all about it's doing my head in the next stop is the only thing i know when all else fails get the hammer out.


  Fruit Bat /\0/\ 13:24 18 Feb 2012

Try Start - Run (search) type cmd

Type (drive letter of your pendisk) chkdsk /F


P: chkdsk /F

press enter

might give you lots of error messages

on completion try formatting again.

  robin_x 13:27 18 Feb 2012

Another idea for your consideration when convenient...

If it's a giveaway USB stick advertising a company, it may be a special that Windows doesn't like.

Try making a gparted boot CD and doing it under Linux. Or use any Linux distro.

How to format USB stick with Ubuntu example.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)