PCMCIA WLAN adapter not working

  Tangy 15:53 30 Nov 2003
Locked

I have a Dell Lattitude CPx J650GT laptop & am using a D-Link Air DWL-610 Wireless Cardbus Adapter.

Last night the adaptor was working fine, but this morning when I switched on the computer it said it found a new device, which was actually the WLAN adapter & installed it. Then I found that the WLAN didn't work.

I proceeded to check the Device Manager & found a yellow exclamation mark next to the entry D-Link Air DWL-610 Wireless Cardbus Adapter #3. The strange thing was, I know that when it was working it used to be Adapter #2. I tried uninstalling it but it was reinstalled itself as Adapter #3 again. This I couldn't figure out so I decided to disable it. What happened next was that when I tried to use the card, the computer reinstalled the card as Adapter #4! Now, for both #3 & #4, the comment for the exclamation was that it couldn't find enough resources for it to work & had 'code 12' in brackets.

Is there any way I can get it back to working on Adapter #2?

Another thing. When I clicked on Device Manager to shown hidden devices, it showed me 'D-Link Air DWL-610 Wireless Cardbus Adapter - Packet Scheduler Miniport' four times. One for each adapter. I tried uninstalling these Miniports, but the system wouldn't let me.

How can I get my WLAN card to work again? Thanks for any help in advance.

  Tangy 20:48 02 Dec 2003

Anyone got any ideas?

  AndySD 21:37 02 Dec 2003

Remove the card from the slot then Add/Remove programs and remove the software. Redoot into safe Mode and remove the info from device manager. Reboot and reinstall the software then the card.

  Tangy 12:03 05 Dec 2003

I tried removing the software, went into safe mode & tried removing the "...Adapter Packet Scheduler Miniport". However, I couldn't & the reason it gave was that "The device may be needed for booting up the computer". I can't see how this 'miniport' is needed for booting up. Any ideas?

  Tangy 20:50 06 Dec 2003

Can anyone help me?

  Tangy 17:43 27 Dec 2003

In the end all I could do was to reinstall Windows. It has solved the problem, but a big hassle due to the amount of software reinstallations.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?