PCMCIA firewire/usb card wont work

  adrian.d 23:45 21 Jun 2005

Can anyone shed any light on why I cannot install a new usb2/firewire card in my laptop running XP Home? I bought it to replace what I thought was a faulty 4 port firewire card. It looks as if the first card might be ok now.

When inserted they both show in device manager but with the alert sign and the error code 10 This device cannot start. I have tried all known methods (to me at least) including removing and reinstalling etc.

I now wonder if there is a fault with the laptop? Any ideas?


  adrian.d 21:25 23 Jun 2005

Still stuck here. Any ideas folks?


  woodchip 21:29 23 Jun 2005

When you say removing do you mean uninstall from Device Manager? If no, then try it that way

  adrian.d 21:45 23 Jun 2005

Both, via Device manager then removing card and reinserting and shutting down the computer and starting with the card in. Seems I've tried all methods.


  woodchip 21:47 23 Jun 2005

What Chipset is the Motherboard? Do You Know?

  woodchip 21:57 23 Jun 2005

You may have to try another card. But it may be windows file corruption. If you have a Full XP System disc put in in comp the from run type SFC /SCANNOW

  adrian.d 22:01 23 Jun 2005

Not sure about the chipset. Will try your other suggestion with the Windows disk.

Thanks. I'll keep you posted.


  woodchip 22:08 23 Jun 2005

Run this for a run down on your computer click here

  adrian.d 23:34 23 Jun 2005

Tried the file scan to no avail. Also downloaded the Everest program. Seems my chipset is an SIS 650.

I'll try to borrow another card from somebody. I cant afford to keep buying them. I'll post my results. Thanks for your help.


  woodchip 20:15 24 Jun 2005

You could try getting a Update Driver for the SIS chipset

  woodchip 20:16 24 Jun 2005

Did you load the Software before you put the card in?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?