PC won't start unless I unplug USB hub

  [DELETED] 19:21 04 Jan 2006
Locked

Hi folks, it's been a while.

I'm running XP Home. I've just bought a 7 port USB 2 hub from Ebuyer click here

This is a powered hub and will also work in passive mode. When I tried to start up the PC I notice that the HDD busy light is on and the PC will not boot. If I disconnect the power to the hub the PC boots up as normal.

This never happened with my Belkin 7 port USB 1 hub.

Any thoughts? I can't send the hub back as I've already dumped the packaging.

Thanks, Bob.

  [DELETED] 11:12 05 Jan 2006

Are you booting from cold, that is to say, are you switching the mains on immediately before booting up?

If yes, try switching the mains on (including the hub) and leaving for a minute or so before pressing the start button on the computer.

My thoughts are that the hub may be taking a time to get itself organised during which it is preventing the computer from starting properly.

Might work, might not but, nothing to lose by trying.

  [DELETED] 11:48 05 Jan 2006

Ed it makes no difference whether I cold boot or boot from the system being switched off at the front of the PC.

It would appear that voltage is coming down the AB lead and somehow keeping the system active.

I've disconnected all usb devices from the hub and just had the hub itself connected and the problem remains. I think it's probably a duff hub but as it only cost £8.22 It'll cost me half that to send it back.

  [DELETED] 12:01 05 Jan 2006

daft? do you connect through ethernet such as broadband modem I have found that occassionally XP will lock into a USB device usually when a CD/DVD is left in the burner going round & round never actually reaching the start
The cure is go to bios and uncheck other boot up device

  [DELETED] 15:15 05 Jan 2006

OK, I've got into the BIOS. Holding down Del button worked.

I disabled USB Legacy support to no avail so I've switched it back to Auto.

I disabled boot from Floppy, just in case, still the same. Reset to previous setting.

I did notice that with the USB Hub's PSU plugged into mains but switched off the power on led is lit when the PC is switched on. I reckon the PSU is FUBAR. Written to ebuyer to see if they will change it even though I've binned the packaging.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best computer security tips

This fantastic short film is packed with hidden TV and film references

Best external graphics cards (eGPUs) for Mac

Test : les écouteurs Bluetooth Soundcore Spirit X d’Anker